Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 448739 - ath5k rate setting is wonky
Summary: ath5k rate setting is wonky
Keywords:
Status: CLOSED DUPLICATE of bug 452491
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL: http://wireless.kernel.org/en/users/D...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-28 14:57 UTC by Brian Jedsen
Modified: 2008-07-01 01:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-23 19:12:33 UTC


Attachments (Terms of Use)

Description Brian Jedsen 2008-05-28 14:57:17 UTC
Description of problem:
The ath5k driver, though most awesome, has a funky way of setting the rate of
the card. When set to auto, it will drop the connection rate to 1MB every second
or so. When the rate is manually set with iwconfig, the connection is dropped
after about 10 seconds.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start large transfer
2. Set rate with iwconfing (iwconfig wlan0 rate 11M)
3. Observe the connection fail
  
Actual results:
Either the rate is set to 1M every second or so, or, if the rate is manually
set, the connection drops.

Expected results:
Free, fast and easy wireless (almost there!).

Additional info:
dmesg reports this: "ath5k phy0: noise floor calibration timeout" every minute
or so.

Comment 1 David Nielsen 2008-05-28 15:09:21 UTC
what kernel release is this on Brian?

Comment 2 Brian Jedsen 2008-05-28 15:11:38 UTC
kernel-2.6.25.3-18.fc9.i686

Thanks for the quick response.

Comment 3 John W. Linville 2008-06-23 19:09:27 UTC
Is this still happening with -55.fc9?

Comment 4 John W. Linville 2008-06-23 19:12:33 UTC

*** This bug has been marked as a duplicate of 452491 ***

Comment 5 Brian Jedsen 2008-07-01 01:50:22 UTC
I'm not having this problem with -55 any longer. I can set the rate to 11MB with
iwconfig and it works without timing out.


Note You need to log in before you can comment on or make changes to this bug.