Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 448288 - firefox crashing repeatedly
Summary: firefox crashing repeatedly
Keywords:
Status: CLOSED DUPLICATE of bug 447444
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-25 13:46 UTC by Jonathan Kamens
Modified: 2018-04-11 06:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-26 14:15:50 UTC


Attachments (Terms of Use)

Description Jonathan Kamens 2008-05-25 13:46:32 UTC
Firefox is crashing repeatedly on me from current Rawhide.  Stack trace of one
of the crashes:


Thread 1 (process 3469):
#0  0x00110416 in __kernel_vsyscall ()
#1  0x00d104e0 in raise (sig=<value optimized out>)
    at ../nptl/sysdeps/unix/sysv/linux/pt-raise.c:42
#2  0x061a7d77 in nsProfileLock::FatalSignalHandler (
    signo=<value optimized out>) at nsProfileLock.cpp:212
#3  <signal handler called>
#4  0x037287e6 in SuggestMgr::~SuggestMgr ()
   from /usr/lib/libhunspell-1.2.so.0
#5  0x03728216 in Hunspell::~Hunspell () from /usr/lib/libhunspell-1.2.so.0
#6  0x0699561c in ~mozHunspell (this=<value optimized out>)
    at mozHunspell.cpp:103
#7  0x06994507 in mozHunspell::Release (this=<value optimized out>)
    at mozHunspell.cpp:78
#8  0x0699c6f1 in nsCOMPtr_base::assign_assuming_AddRef (
    this=<value optimized out>, newPtr=<value optimized out>)
    at ../glue/nsCOMPtr.h:531
#9  0x0699c52a in nsCOMPtr_base::assign_with_AddRef (
    this=<value optimized out>, rawPtr=<value optimized out>)
    at nsCOMPtr.cpp:89
#10 0x069cd399 in FreeServiceContractIDEntryEnumerate (aTable=Could not find the
frame base for "FreeServiceContractIDEntryEnumerate".
)
    at ../../dist/include/xpcom/nsCOMPtr.h:1060
#11 0x0699ad28 in PL_DHashTableEnumerate (table=<value optimized out>, 
    etor=<value optimized out>, arg=<value optimized out>) at pldhash.c:724
#12 0x069cd854 in nsComponentManagerImpl::FreeServices (
    this=<value optimized out>) at nsComponentManager.cpp:1820
#13 0x069a4828 in NS_ShutdownXPCOM_P (servMgr=<value optimized out>)
    at nsXPComInit.cpp:775
#14 0x0619e3ed in ~ScopedXPCOMStartup (this=<value optimized out>)
    at nsAppRunner.cpp:909
#15 0x061a0ac9 in XRE_main (argc=<value optimized out>, 
    argv=<value optimized out>, aAppData=<value optimized out>)
    at nsAppRunner.cpp:3211
#16 0x08049169 in main (argc=2, argv=0xbfd42714) at nsXULStub.cpp:364

Comment 1 Matěj Cepl 2008-05-26 14:15:50 UTC

*** This bug has been marked as a duplicate of 447444 ***


Note You need to log in before you can comment on or make changes to this bug.