Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 448098 - Message ---> an error has occurred in firstboot_kdump module.
Summary: Message ---> an error has occurred in firstboot_kdump module.
Keywords:
Status: CLOSED DUPLICATE of bug 508167
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-kdump
Version: 10
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Roman Rakus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 473389 475143 478500 479449 482969 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-23 13:50 UTC by john posey
Modified: 2014-01-13 00:07 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-31 07:27:57 UTC


Attachments (Terms of Use)
dummy file (because i can't erase file to attach box above) (deleted)
2008-05-23 13:50 UTC, john posey
no flags Details

Description john posey 2008-05-23 13:50:16 UTC
When first boot up after installation an error occurred.

-----------------------------------------
see below (attachment replacement)
[root@localhost tmp]# cat firstbootydhmMl 
Traceback (most recent call last):
  File "/usr/lib64/python2.5/site-packages/firstboot/loader.py", line 87, in
loadModules
    loaded = imputil.imp.load_module(module, found[0], found[1], found[2])
  File "/usr/share/firstboot/modules/firstboot_kdump.py", line 34, in <module>
    import functions
ImportError: No module named functions
--------------------------------------------
[root@localhost firstboot]# pwd
/usr/lib64/python2.5/site-packages/firstboot
[root@localhost firstboot]# ls -l
total 216
-rw-r--r-- 1 root root  1170 2008-04-16 08:01 config.py
-rw-r--r-- 2 root root   684 2008-04-16 08:14 config.pyc
-rw-r--r-- 2 root root   684 2008-04-16 08:14 config.pyo
-rw-r--r-- 1 root root  1077 2008-04-16 08:01 constants.py
-rw-r--r-- 2 root root   332 2008-04-16 08:14 constants.pyc
-rw-r--r-- 2 root root   332 2008-04-16 08:14 constants.pyo
-rw-r--r-- 1 root root  3291 2008-04-16 08:01 exceptionWindow.py
-rw-r--r-- 2 root root  3169 2008-04-16 08:14 exceptionWindow.pyc
-rw-r--r-- 2 root root  3169 2008-04-16 08:14 exceptionWindow.pyo
-rw-r--r-- 1 root root   448 2008-04-16 08:01 functions.py
-rw-r--r-- 2 root root  1018 2008-04-16 08:14 functions.pyc
-rw-r--r-- 2 root root  1018 2008-04-16 08:14 functions.pyo
-rw-r--r-- 1 root root     0 2008-04-16 08:01 __init__.py
-rw-r--r-- 2 root root   143 2008-04-16 08:14 __init__.pyc
-rw-r--r-- 2 root root   143 2008-04-16 08:14 __init__.pyo
-rw-r--r-- 1 root root 20011 2008-04-16 08:01 interface.py
-rw-r--r-- 2 root root 15231 2008-04-16 08:14 interface.pyc
-rw-r--r-- 2 root root 15231 2008-04-16 08:14 interface.pyo
-rw-r--r-- 1 root root  5764 2008-04-16 08:01 loader.py
-rw-r--r-- 2 root root  4651 2008-04-16 08:14 loader.pyc
-rw-r--r-- 2 root root  4651 2008-04-16 08:14 loader.pyo
-rw-r--r-- 1 root root  9441 2008-04-16 08:01 module.py
-rw-r--r-- 2 root root  9602 2008-04-16 08:14 module.pyc
-rw-r--r-- 2 root root  9602 2008-04-16 08:14 module.pyo
-rw-r--r-- 1 root root  7348 2008-04-16 08:01 moduleset.py
-rw-r--r-- 2 root root  7620 2008-04-16 08:14 moduleset.pyc
-rw-r--r-- 2 root root  7620 2008-04-16 08:14 moduleset.pyo
-rw-r--r-- 1 root root  1689 2008-04-16 08:01 rhgbfrontend.py
-rw-r--r-- 2 root root  1364 2008-04-16 08:14 rhgbfrontend.pyc
-rw-r--r-- 2 root root  1364 2008-04-16 08:14 rhgbfrontend.pyo
-rw-r--r-- 1 root root  3492 2008-04-16 08:01 xfrontend.py
-rw-r--r-- 2 root root  3002 2008-04-16 08:14 xfrontend.pyc
-rw-r--r-- 2 root root  3002 2008-04-16 08:14 xfrontend.pyo

[root@localhost firstboot]# pwd
/usr/lib64/python2.5/site-packages/firstboot
[root@localhost firstboot]# ls -l
total 216
-rw-r--r-- 1 root root  1170 2008-04-16 08:01 config.py
-rw-r--r-- 2 root root   684 2008-04-16 08:14 config.pyc
-rw-r--r-- 2 root root   684 2008-04-16 08:14 config.pyo
-rw-r--r-- 1 root root  1077 2008-04-16 08:01 constants.py
-rw-r--r-- 2 root root   332 2008-04-16 08:14 constants.pyc
-rw-r--r-- 2 root root   332 2008-04-16 08:14 constants.pyo
-rw-r--r-- 1 root root  3291 2008-04-16 08:01 exceptionWindow.py
-rw-r--r-- 2 root root  3169 2008-04-16 08:14 exceptionWindow.pyc
-rw-r--r-- 2 root root  3169 2008-04-16 08:14 exceptionWindow.pyo
-rw-r--r-- 1 root root   448 2008-04-16 08:01 functions.py
-rw-r--r-- 2 root root  1018 2008-04-16 08:14 functions.pyc
-rw-r--r-- 2 root root  1018 2008-04-16 08:14 functions.pyo
-rw-r--r-- 1 root root     0 2008-04-16 08:01 __init__.py
-rw-r--r-- 2 root root   143 2008-04-16 08:14 __init__.pyc
-rw-r--r-- 2 root root   143 2008-04-16 08:14 __init__.pyo
-rw-r--r-- 1 root root 20011 2008-04-16 08:01 interface.py
-rw-r--r-- 2 root root 15231 2008-04-16 08:14 interface.pyc
-rw-r--r-- 2 root root 15231 2008-04-16 08:14 interface.pyo
-rw-r--r-- 1 root root  5764 2008-04-16 08:01 loader.py
-rw-r--r-- 2 root root  4651 2008-04-16 08:14 loader.pyc
-rw-r--r-- 2 root root  4651 2008-04-16 08:14 loader.pyo
-rw-r--r-- 1 root root  9441 2008-04-16 08:01 module.py
-rw-r--r-- 2 root root  9602 2008-04-16 08:14 module.pyc
-rw-r--r-- 2 root root  9602 2008-04-16 08:14 module.pyo
-rw-r--r-- 1 root root  7348 2008-04-16 08:01 moduleset.py
-rw-r--r-- 2 root root  7620 2008-04-16 08:14 moduleset.pyc
-rw-r--r-- 2 root root  7620 2008-04-16 08:14 moduleset.pyo
-rw-r--r-- 1 root root  1689 2008-04-16 08:01 rhgbfrontend.py
-rw-r--r-- 2 root root  1364 2008-04-16 08:14 rhgbfrontend.pyc
-rw-r--r-- 2 root root  1364 2008-04-16 08:14 rhgbfrontend.pyo
-rw-r--r-- 1 root root  3492 2008-04-16 08:01 xfrontend.py
-rw-r--r-- 2 root root  3002 2008-04-16 08:14 xfrontend.pyc
-rw-r--r-- 2 root root  3002 2008-04-16 08:14 xfrontend.pyo

Comment 1 john posey 2008-05-23 13:50:16 UTC
Created attachment 306498 [details]
dummy file (because i can't erase file to attach box above)

Comment 2 john posey 2008-05-23 14:01:14 UTC
(In reply to comment #0)
correction to duplicate info ---> 

[root@localhost firstboot]# cd /usr/share/firstboot/modules/
[root@localhost modules]# ls -l
total 136
-rw-r--r-- 1 root root  9645 2008-04-16 08:01 create_user.py
-rw-r--r-- 2 root root  7301 2008-04-16 08:14 create_user.pyc
-rw-r--r-- 2 root root  7301 2008-04-16 08:14 create_user.pyo
-rw-r--r-- 1 root root  2243 2008-04-16 08:01 date.py
-rw-r--r-- 2 root root  2261 2008-04-16 08:14 date.pyc
-rw-r--r-- 2 root root  2261 2008-04-16 08:14 date.pyo
-rw-r--r-- 1 root root  2920 2008-04-16 08:01 eula.py
-rw-r--r-- 2 root root  2779 2008-04-16 08:14 eula.pyc
-rw-r--r-- 2 root root  2779 2008-04-16 08:14 eula.pyo
lrwxrwxrwx 1 root root    35 2008-05-23 01:52 firstboot_kdump.py ->
/usr/share/kdump/firstboot_kdump.py
-rw-r--r-- 1 root root 10863 2008-05-23 01:56 firstboot_kdump.pyc
lrwxrwxrwx 1 root root    49 2008-05-23 01:52 keyboard.py ->
/usr/share/system-config-keyboard/keyboard_gui.py
-rw-r--r-- 1 root root  7901 2008-05-23 02:06 keyboard.pyc
lrwxrwxrwx 1 root root    49 2008-05-23 01:03 language.py ->
/usr/share/system-config-language/language_gui.py
-rw-r--r-- 1 root root 10183 2008-05-23 01:56 language.pyc
lrwxrwxrwx 1 root root    50 2008-05-23 01:04 rootpassword.py ->
../../system-config-rootpassword/passwordDialog.py
-rw-r--r-- 2 root root  7474 2008-04-02 05:43 rootpassword.pyc
-rw-r--r-- 2 root root  7474 2008-04-02 05:43 rootpassword.pyo
-rw-r--r-- 1 root root  4501 2008-03-08 12:57 smolt.py
-rw-r--r-- 2 root root  4752 2008-04-03 15:43 smolt.pyc
-rw-r--r-- 2 root root  4752 2008-04-03 15:43 smolt.pyo
-rw-r--r-- 1 root root  2380 2008-04-16 08:01 welcome.py
-rw-r--r-- 2 root root  2140 2008-04-16 08:14 welcome.pyc
-rw-r--r-- 2 root root  2140 2008-04-16 08:14 welcome.pyo


Comment 3 Jerry Amundson 2008-12-27 05:14:13 UTC
*** Bug 475143 has been marked as a duplicate of this bug. ***

Comment 4 Qian Cai 2009-08-31 04:18:15 UTC
*** Bug 478500 has been marked as a duplicate of this bug. ***

Comment 5 Qian Cai 2009-08-31 04:18:50 UTC
*** Bug 479449 has been marked as a duplicate of this bug. ***

Comment 6 Qian Cai 2009-08-31 04:19:17 UTC
*** Bug 473389 has been marked as a duplicate of this bug. ***

Comment 7 Qian Cai 2009-08-31 04:19:32 UTC
*** Bug 482969 has been marked as a duplicate of this bug. ***

Comment 8 Roman Rakus 2009-08-31 07:27:57 UTC

*** This bug has been marked as a duplicate of bug 508167 ***


Note You need to log in before you can comment on or make changes to this bug.