Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 447850 - cannot launch SCIM after fresh install
Summary: cannot launch SCIM after fresh install
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: im-chooser
Version: 9
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-22 04:54 UTC by Yolkfull Chow
Modified: 2009-06-23 06:53 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-06-23 06:53:05 UTC


Attachments (Terms of Use)
the conf file under /etc/X11/xinit/xinput.d (deleted)
2008-05-22 07:44 UTC, Yolkfull Chow
no flags Details
the conf file under /etc/X11/xinit/xinput.d (deleted)
2008-05-22 07:45 UTC, Yolkfull Chow
no flags Details
the conf file under /etc/X11/xinit/xinput.d (deleted)
2008-05-22 07:45 UTC, Yolkfull Chow
no flags Details

Description Yolkfull Chow 2008-05-22 04:54:46 UTC
Description of problem:
SCIM can not be launched after fresh install F9. If launch it in terminal,
following error messages will appear:
.....
Loading x11
Failed to load x11 FrontEnd module...
SCIM has exited abnormally.

Version-Release number of selected component (if applicable):
scim-1.4.7-23.fc9.i386

How reproducible:
Everytime

Steps to Reproduce:
1. fresh install f9
2. after install completely, launch SCIM in terminal
  
Actual results:
Cannot launch SCIM.

Expected results:
SCIM could be launched successfully.

Additional info:
First time to launch SCIM in terminal will not get any error message though SCIM
will not be launched successfully. And the error messages will appear after
secondly launch it. Following are what I get when I launch SCIM:

[root@localhost ~]# scim &
[1] 2955
[root@localhost ~]# Smart Common Input Method 1.4.7

Launching a SCIM daemon with Socket FrontEnd...
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
Launching a SCIM process with x11...
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
GTK Panel of SCIM 1.4.7

Starting SCIM ...

[root@localhost ~]# scim &
[2] 3045
Smart Common Input Method 1.4.7

[root@localhost ~]# Launching a SCIM process with x11...
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
Failed to load x11 FrontEnd module.
SCIM has exited abnormally.

[2]+  Exit 1                  scim

Comment 1 Jens Petersen 2008-05-22 06:01:54 UTC
It is not a good idea to start scim from the commandline.

Have you tried using im-chooser?

Comment 2 Yolkfull Chow 2008-05-22 06:26:52 UTC
Just tried using im-chooser whereas get following messages along with a pop-up
window noticing that "No input method is available".
------------------------------------
[yzhou@localhost Download]$ im-chooser

(im-chooser:16671): IMSettings-WARNING **: Failed to invoke a method `GetList':
  No input methods available on your system.

(im-chooser:16671): IMSettings-WARNING **: Failed to invoke a method
`WhatInputMethodIsRunning':
  No such input method on your system: SCIM
---------------------------

$ yum list | grep scim
scim.i386                                1.4.7-23.fc9           installed       
scim-anthy.i386                          1.2.4-4.fc9            installed       
scim-array.i386                          0.0.4-0.fc9            installed       
scim-bridge.i386                         0.4.15-5.fc9           installed       
scim-bridge-gtk.i386                     0.4.15-5.fc9           installed       
scim-bridge-qt.i386                      0.4.15-5.fc9           installed       
scim-bridge-qt3.i386                     0.4.15-5.fc9           installed       
scim-chewing.i386                        0.3.1-13.fc9           installed       
scim-devel.i386                          1.4.7-23.fc9           installed       
scim-doc.i386                            1.4.7-23.fc9           installed       
scim-fcitx.i386                          3.1.1-9.fc9            installed       
scim-fcitx-tools.i386                    3.1.1-9.fc9            installed       
scim-gtk.i386                            1.4.7-23.fc9           installed       
scim-hangul.i386                         0.3.2-4.fc9            installed       
scim-input-pad.i386                      0.1.1-8.fc9            installed       
scim-lang-assamese.i386                  1.4.7-23.fc9           installed       
scim-lang-bengali.i386                   1.4.7-23.fc9           installed       
scim-lang-chinese.i386                   1.4.7-23.fc9           installed       
scim-lang-dhivehi.i386                   1.4.7-23.fc9           installed       
scim-lang-farsi.i386                     1.4.7-23.fc9           installed       
scim-lang-gujarati.i386                  1.4.7-23.fc9           installed       
scim-lang-hindi.i386                     1.4.7-23.fc9           installed       
scim-lang-japanese.i386                  1.4.7-23.fc9           installed       
scim-lang-kannada.i386                   1.4.7-23.fc9           installed       
scim-lang-korean.i386                    1.4.7-23.fc9           installed       
scim-lang-latin.i386                     1.4.7-23.fc9           installed       
scim-lang-malayalam.i386                 1.4.7-23.fc9           installed       
scim-lang-marathi.i386                   1.4.7-23.fc9           installed       
scim-lang-nepali.i386                    1.4.7-23.fc9           installed       
scim-lang-oriya.i386                     1.4.7-23.fc9           installed       
scim-lang-punjabi.i386                   1.4.7-23.fc9           installed       
scim-lang-sinhalese.i386                 1.4.7-23.fc9           installed       
scim-lang-tamil.i386                     1.4.7-23.fc9           installed       
scim-lang-telugu.i386                    1.4.7-23.fc9           installed       
scim-lang-thai.i386                      1.4.7-23.fc9           installed       
scim-lang-tibetan.i386                   1.4.7-23.fc9           installed       
scim-libs.i386                           1.4.7-23.fc9           installed       
scim-m17n.i386                           0.2.2-3.fc9            installed       
scim-pinyin.i386                         0.5.91-25.fc9          installed       
scim-python.i386                         0.1.12-1.fc9           installed       
scim-python-chinese.i386                 0.1.12-1.fc9           installed       
scim-python-english.i386                 0.1.12-1.fc9           installed       
scim-python-pinyin.i386                  0.1.12-1.fc9           installed       
scim-python-xingma.i386                  0.1.12-1.fc9           installed       
scim-python-xingma-cangjie.i386          0.1.12-1.fc9           installed       
scim-python-xingma-erbi.i386             0.1.12-1.fc9           installed       
scim-python-xingma-wubi.i386             0.1.12-1.fc9           installed       
scim-python-xingma-zhengma.i386          0.1.12-1.fc9           installed       
scim-qtimm.i386                          0.9.4-10.fc9           installed       
scim-rawcode.i386                        1.4.7-23.fc9           installed       
scim-sinhala.i386                        0.2.0-6.fc9            installed       
scim-skk.i386                            0.5.2-8.fc6            installed       
scim-tables.i386                         0.5.7-5.fc9            installed       
scim-tables-additional.i386              0.5.7-5.fc9            installed       
scim-tables-amharic.i386                 0.5.7-5.fc9            installed       
scim-tables-arabic.i386                  0.5.7-5.fc9            installed       
scim-tables-chinese.i386                 0.5.7-5.fc9            installed       
scim-tables-nepali.i386                  0.5.7-5.fc9            installed       
scim-tables-russian.i386                 0.5.7-5.fc9            installed       
scim-tables-thai.i386                    0.5.7-5.fc9            installed       
scim-tables-vietnamese.i386              0.5.7-5.fc9            installed       
scim-tomoe.i386                          0.6.0-2.fc8            installed 

BTW,I am sure this problem didn't happen on F8.

Comment 3 Jens Petersen 2008-05-22 06:39:02 UTC
Hmm, what is your version of im-chooser?

Did you update to the latest version?
There was a bugfix update that went out in the last day.

Comment 4 Yolkfull Chow 2008-05-22 07:00:24 UTC
Petersen:
Yes, I updated it to the latest version but can not launch it nor.

# yum list | grep im-chooser
im-chooser.i386                          0.99.6-4.fc9           installed 

# im-chooser &
[1] 17067
[root@localhost ~]# No protocol specified

(im-chooser:17067): Gtk-WARNING **: cannot open display: :0.0

[1]+  Exit 1                  im-chooser

I have not tried to restart or logout the current user as mentioned in bug#445129.

Comment 5 Akira TAGOH 2008-05-22 07:08:21 UTC
Try your real user but not root on su or sudo session.

Comment 6 Akira TAGOH 2008-05-22 07:11:46 UTC
one more point, try it on the local host, but not from the remote host.

Comment 7 Yolkfull Chow 2008-05-22 07:16:50 UTC
Akira,

I tried the user that I logged in after system boot up on my local host, also
failed.

[yzhou@localhost scim]$ im-chooser &
[1] 17280
[yzhou@localhost scim]$ 
(im-chooser:17280): IMSettings-WARNING **: Failed to invoke a method `GetList':
  No input methods available on your system.

(im-chooser:17280): IMSettings-WARNING **: Failed to invoke a method
`WhatInputMethodIsRunning':
  No such input method on your system: SCIM

(im-chooser:17280): atk-bridge-WARNING **: failure: no device event controller
found.


(im-chooser:17280): atk-bridge-WARNING **: failure: no device event controller
found.


[1]+  Exit 1                  im-chooser
[yzhou@localhost scim]$ rpm -qa im-chooser
im-chooser-0.99.6-4.fc9.i386

Comment 8 Akira TAGOH 2008-05-22 07:28:37 UTC
Hmm, that error basically means what you can see AS IS. do you have any conf
files under /etc/X11/xinit/xinput.d ? and what locale are you running on?

Comment 9 Yolkfull Chow 2008-05-22 07:44:51 UTC
Created attachment 306345 [details]
the conf file under /etc/X11/xinit/xinput.d

Comment 10 Yolkfull Chow 2008-05-22 07:45:22 UTC
Created attachment 306346 [details]
the conf file under /etc/X11/xinit/xinput.d

Comment 11 Yolkfull Chow 2008-05-22 07:45:56 UTC
Created attachment 306347 [details]
the conf file under /etc/X11/xinit/xinput.d

Comment 12 Yolkfull Chow 2008-05-22 07:48:40 UTC
There are in all three conf files under this directory, please see
attachement.As for lacale, Akira, do you mean graphic environment? If yes, it is
Gnome.

Comment 13 Yolkfull Chow 2008-05-22 08:03:33 UTC
Sorry Akira for my wrongly understanding. I have en_US running on my system.

Comment 14 Akira TAGOH 2008-05-22 09:32:37 UTC
Summary after we talked on IRC, after restarting im-info-daemon and
im-settings-daemon, warnings seems to be gone. so the older incompatible
processes may be running.
This is my analysis. this seems to be fresh install though, then no such
warnings, "No such input method on your system: SCIM" reported, because this
means $HOME/.xinputrc points to scim.conf and since this is on en_US locale,
SCIM isn't a default IM for the system wide. thus that may means im-chooser may
be brought up once and changed IM configuration for using SCIM. this is really
weird.
I was suspecting it may be not a fresh install but upgrading from older release.
but seems not. so I have no clue why it happened.

Just for record,

Comment 15 Akira TAGOH 2008-05-22 09:33:46 UTC
Any additional info are welcome. how to reproduce this issue with the detailed
steps etc.

Comment 16 Tony Fu 2008-09-10 03:11:01 UTC
requested by Jens Petersen (#27995)

Comment 17 Bug Zapper 2009-06-10 01:04:50 UTC
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.