Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 447731 - frequent freezes with trace
Summary: frequent freezes with trace
Keywords:
Status: CLOSED DUPLICATE of bug 447444
Alias: None
Product: Fedora
Classification: Fedora
Component: xulrunner
Version: rawhide
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-21 13:41 UTC by Patrice Dumas
Modified: 2018-04-11 14:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-23 06:11:42 UTC


Attachments (Terms of Use)
glibc trace associated with the freeze (deleted)
2008-05-21 13:41 UTC, Patrice Dumas
no flags Details
trace with sqlite 3.5.4 (deleted)
2008-05-21 22:10 UTC, Patrice Dumas
no flags Details

Description Patrice Dumas 2008-05-21 13:41:38 UTC
Description of problem:

firefox freezes with a trace that I attach.
I still haven't understood what causes it to freeze, it seems
to be random. It doesn't really crashes, but is left with an
empty window. There is a trace on the console when firefox is 
launched on the command line. The trace is always the same.
It happens very frequently.

In the trace there are reference to hunspell, so maybe the bug
is in hunspell.

I haven't found the same bug already entered which is a bit strange,
maybe there is something in my setup that could explain that I am
the only one seeing it, but I don't know what it could be.

I tried to get a better backtrace in gdb, but when launched in
gdb (with firefox -g) there is no problem... Maybe it is because 
it is slowed down?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Patrice Dumas 2008-05-21 13:41:38 UTC
Created attachment 306250 [details]
glibc trace associated with the freeze

Comment 2 Ralf Ertzinger 2008-05-21 16:28:25 UTC
Happens reliably for me when opening
http://einestages.spiegel.de/static/topicalbumbackground/1771/die_ahnen_von_star_w

Happens even when firefox is started in safe-mode

Comment 3 Ralf Ertzinger 2008-05-21 16:30:07 UTC
Well, bugzilla (or konqueror) munges long URLs.

So this is the same one:
http://tinyurl.com/4pbysr

Comment 4 Christopher Aillon 2008-05-21 19:35:10 UTC
workaround: downgrade your sqlite copy to 3.5.4

Comment 5 Patrice Dumas 2008-05-21 22:09:44 UTC
That didn't worked. I still get a similr trace, I attach it.

Comment 6 Patrice Dumas 2008-05-21 22:10:42 UTC
Created attachment 306321 [details]
trace with sqlite 3.5.4

Comment 7 Christopher Aillon 2008-05-22 04:46:38 UTC
Er, sorry, meant to say to downgrade hunspell (which other apps will complain
about likely.. but it will fix firefox at least.)

Comment 8 Patrice Dumas 2008-05-22 07:47:58 UTC
xulrunner requires
libhunspell-1.2.so.0  
provided by hunspell-1.2.2, the previous version is 1.2.1 which 
provides libhunspell.so.1, so xulrunner will also complain.

I can do a compat package for hunspell (parallel installable) and
rebuild xulrunner, but I am not sure it is worth it, hopefully this
bug will be fixed soon.

Comment 9 Matěj Cepl 2008-05-23 06:11:42 UTC

*** This bug has been marked as a duplicate of 447444 ***


Note You need to log in before you can comment on or make changes to this bug.