Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 447500 - no network with static ip
Summary: no network with static ip
Keywords:
Status: CLOSED DUPLICATE of bug 134886
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 9
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-20 07:09 UTC by Adam Sobotka
Modified: 2008-07-03 14:09 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-02 23:01:53 UTC


Attachments (Terms of Use)

Description Adam Sobotka 2008-05-20 07:09:11 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Just fresh install fedora 9 with static IP specified in install process.

Steps to Reproduce:
1.Run through installation process
2.Fill your static ip in system-config-network like dialog in anaconda
3.
  
Actual results:
No network, you have to fix manually that interface is managed by network manager.

Expected results:
I expected that for static adressing there is old network service. 

Additional info:
It might be, but when you have another (wifi) network card, nm probably steps in
play and destruct whole configuration. This bug have easy fix, just remove
config dialog in anaconda. When I ignored him in fresh install and then set
everything in nm-applet, it works like charm.

Comment 1 Dan Williams 2008-05-23 16:07:16 UTC
Could you update to the version of NM in f9-updates-testing?

yum update --enable-repo updates-testing NetworkManager*

and try that?  It should fix a few of the problems with NM that users were
experiencing with install-time static IP configuration.

Comment 2 Adam Sobotka 2008-05-23 16:48:42 UTC
Hello,
as I said...problem occurs only when I set static IP in installation process.
When I did not fill my ip in anaconda,everything worked fine.
So, if I make clean install again with filled ip, I would not get network
connectivity to update nm as you propose.

Comment 3 Jan "Yenya" Kasprzak 2008-05-27 11:03:34 UTC
The same here, even with NetworkManager-0.7.0-0.9.3svn3669.fc9.i386.
On a fresh install (even after yum update and installing the above
NetworkManager), the network is not started when a static IP address is
specified during install.

chkconfig NetworkManager off
chkconfig network on

fixes the problem.


Comment 4 Dan Williams 2008-07-02 23:01:53 UTC
Static IPs are fixed in latest F9 updates (svn3675).

*** This bug has been marked as a duplicate of 134886 ***

Comment 5 Jan "Yenya" Kasprzak 2008-07-03 14:09:30 UTC
Re: comment #4

No, they are not fixed. I have just installed a fresh F9 (with a static IP
address), rebooted, manually activated the network (/sbin/ifup eth0), ran yum
update (so I have now NetworkManager-0.7.0-0.9.4.svn3675.fc9.x86_64), and after
the reboot the network is still not being activated.

chkconfig NetworkManager off
chkconfig network on

fixes the problem, though (I wonder why this is not the default, esp. for
non-workstation systems).




Note You need to log in before you can comment on or make changes to this bug.