Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4475 - cannot run "xdos"
Summary: cannot run "xdos"
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: dosemu
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-11 17:30 UTC by prabirm
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-25 03:20:07 UTC


Attachments (Terms of Use)

Description prabirm 1999-08-11 17:30:05 UTC
When I executed "xdos" I got error:
=====>
Error in /var/lib/dosemu/global.conf: (line 643)
Disk-device/file /var/lib/dosemu/hdimage.first doesn't
exist.
<=====
So, I copied existing "/var/lib/dosemu/hdimage" to
"/var/lib/dosemu/hdimage.first". Now I run "xdos"
again and I get error:
======>
[root@localhost /root]# xdos
kernel CPU speed is 233866290 Hz
Running on CPU=586, FPU=1
ERROR: X: Unable to open font "vga"ERROR: , trying "vga"...
ERROR: X: Unable to open font "vga"ERROR: , trying "9x15"...
<======

Then I tried to run "xtermdos" and I get the following
error:
======>
[root@localhost dosemu]# xtermdos
Hey...I could not find the IBM VGA font for xwindows!
To install the VGA font, go into the DOSEMU source directory
and type:
sh xinstallvgafont

Starting xdosemu with default font.  If not using the VGA
font, you should use
the latin character set instead of the PC character set in
/etc/dosemu.conf.

ERROR: No xterm programs found in /usr/X11/bin
Perhaps you don't have Xwindows installed that way?
<========

How do I solve the problem ? BTW, I am running GNOME/KDE
under X perfectly.

Regards,
Prabir

Comment 1 Jay Freeman 1999-09-04 20:34:59 UTC
hdimage.first problem is fixed, don't know if this was always the
case, and you simply didn't have dosemu-freedos installed, or if this
is a more recent fix:

[root(2)@ironclad dosemu]# rpm -q dosemu-freedos
dosemu-freedos-0.99.10-6
[root(2)@ironclad dosemu]# rpm -q --scripts dosemu-freedos
postinstall script (through /bin/sh):
[ -e /var/lib/dosemu/hdimage.first ] || \
    ln -s hdimage.freedos /var/lib/dosemu/hdimage.first
postuninstall script (through /bin/sh):
if [ $1 = 0 ]; then
  if [ -e /var/lib/dosemu/hdimage.first ]; then
    rm -f /var/lib/dosemu/hdimage.first
  fi
fi

Comment 2 Jay Freeman 1999-09-04 20:39:59 UTC
VGA font problem has also been fixed:

[root(2)@ironclad misc]# rpm -q xdosemu
xdosemu-0.99.10-6
[root(2)@ironclad misc]# rpm -ql xdosemu | grep vga
/usr/X11R6/lib/X11/fonts/misc/vga.pcf

Now if only someone at RedHat would notice the added comments and
close the bug report :).

Comment 3 Bill Nottingham 1999-09-25 03:20:59 UTC
OK, we can do that.


Note You need to log in before you can comment on or make changes to this bug.