Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 447347 - crash in gpk-update-viewer
Summary: crash in gpk-update-viewer
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 448047 448961 449093 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-19 16:20 UTC by Charles R. Anderson
Modified: 2008-06-14 12:47 UTC (History)
4 users (show)

Fixed In Version: 0.1.12-13.20080522.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-31 02:17:37 UTC


Attachments (Terms of Use)
bug report generated by crash dialog (deleted)
2008-05-19 16:20 UTC, Charles R. Anderson
no flags Details
output from gpk-update-viewer --verbose (deleted)
2008-05-21 22:35 UTC, Charles R. Anderson
no flags Details
bug report generated by crash dialog (deleted)
2008-05-21 22:36 UTC, Charles R. Anderson
no flags Details
gdb backtrace (deleted)
2008-05-22 16:18 UTC, Charles R. Anderson
no flags Details

Description Charles R. Anderson 2008-05-19 16:20:38 UTC
Description of problem:

gpk-update-viewer crashed when viewing details about yum package update.

Version-Release number of selected component (if applicable):
gnome-packagekit-0.1.12-12.20080430.fc9.i386

How reproducible:
always

Steps to Reproduce:
1. click applet, show updates
2. Review
3. Click on "yum-3.2.16-1.fc9 (noarch)" in list
4. crash
  
Actual results:

see attachment

Comment 1 Charles R. Anderson 2008-05-19 16:20:38 UTC
Created attachment 305972 [details]
bug report generated by crash dialog

Comment 2 Richard Hughes 2008-05-20 07:58:33 UTC
Is this reproducable? What's the output of "gpk-update-viewer --verbose" when
this happens? Thanks.

Comment 3 Charles R. Anderson 2008-05-21 22:35:46 UTC
Created attachment 306323 [details]
output from gpk-update-viewer --verbose

Yes, I did a brand new fresh install of Fedora 9 (using Live media
incidentally, but it doesn't matter), enabled the updates-testing repo, then
did the steps above except running gpk-update-viewer manually as suggested. 
Different system, same crash.

Here is the output.

Comment 4 Charles R. Anderson 2008-05-21 22:36:30 UTC
Created attachment 306324 [details]
bug report generated by crash dialog

Latest bug report output from this attempt.

Comment 5 Richard Hughes 2008-05-22 08:37:28 UTC
Hmm, thanks for your logs. I can't reproduce, but then I can't access the yum
update. Could you please:

1. install the gnome-packagekit-debuginfo package
2. type: 

gdb /usr/bin/gpk-update-viewer
run --verbose

and navigate to the yum entry to make it crash. When it crashes, please type:

bt

into the console and attach the output here. Thanks!

Richard.


Comment 6 Charles R. Anderson 2008-05-22 16:18:42 UTC
Created attachment 306397 [details]
gdb backtrace

output from run through gdb with debuginfos installed

Comment 7 Richard Hughes 2008-05-22 16:46:00 UTC
Cheers for the dump, that's exactly what I needed to see:

https://bugzilla.redhat.com/show_bug.cgi?id=446248;yum doesn't tolerate broken
mirrorlist in cache;
https://bugzilla.redhat.com/show_bug.cgi?id=446186;broken comps.xml; language
support was not installed;
https://bugzilla.redhat.com/show_bug.cgi?id=261961;Yum does not like non-ascii
package names;
https://bugzilla.redhat.com/show_bug.cgi?id=442232;yum doesn't try other mirrors
after hitting ctrnl-c;
https://bugzilla.redhat.com/show_bug.cgi?id=442819;Yum crash when metadata
doesn't match checksum, and there's no other mirrors to try

You'll notice the delimiter in the list is a ';', and string "broken comps.xml;
language support was not installed" conatins an "extra" delimiter.

Of course, the bug is that PackageKit does not pass back an 'as' structure, but
instead a delimited 's' entry, but that's on the list of things to change when
we next break API again (not anytime soon).

If you open /usr/share/PackageKit/helpers/yum/yumBackend.py (as root) and then
search for "urls[typ].append" you'll find this block of code:

                for ref in refs:
                    typ = ref['type']
                    href = ref['href']
                    title = ref['title'] or ""
                    if href:
                        if typ in ('bugzilla','cve'):
                            urls[typ].append("%s;%s" % (href,title))
                        else:
                            urls['vendor'].append("%s;%s" % (href,title))

Can you try changing it to:

                for ref in refs:
                    typ = ref['type']
                    href = ref['href']
                    title = ref['title'].replace(";","") or ""
                    if href:
                        if typ in ('bugzilla','cve'):
                            urls[typ].append("%s;%s" % (href,title))
                        else:
                            urls['vendor'].append("%s;%s" % (href,title))

i.e. you need to add .replace(";","") to one of the lines.

And then save the file. Then try looking at the yum update and checking for the
crash.

If this works, I'll push a PackageKit update into updates testing. Many thanks.


Comment 8 Richard Hughes 2008-05-22 16:48:05 UTC
You might have to do:

                    title = ref['title'] or ""
                    title = title.replace(";","")

I'm not a python legend.

Comment 9 Charles R. Anderson 2008-05-22 17:03:44 UTC
The first fix in Comment #7 worked fine.  I might suggest replacing with a
different character such as "," or ":" though, since losing the ; could change
the meaning of the text too much.


Comment 10 Fedora Update System 2008-05-22 20:40:59 UTC
PackageKit-0.1.12-13.20080522.fc9 has been submitted as an update for Fedora 9

Comment 11 Fedora Update System 2008-05-29 02:52:39 UTC
PackageKit-0.1.12-13.20080522.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PackageKit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4646

Comment 12 Richard Hughes 2008-05-30 09:08:55 UTC
*** Bug 448961 has been marked as a duplicate of this bug. ***

Comment 13 Richard Hughes 2008-05-30 12:09:31 UTC
*** Bug 449093 has been marked as a duplicate of this bug. ***

Comment 14 Fedora Update System 2008-05-31 02:17:32 UTC
PackageKit-0.1.12-13.20080522.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Peter H. Jones 2008-06-14 12:41:03 UTC
*** Bug 448047 has been marked as a duplicate of this bug. ***

Comment 16 Peter H. Jones 2008-06-14 12:47:45 UTC
Regarding comment #11, please see attachment #309360 [details], which I submitted to bug
#448047, before marking the latter as a duplicate of this one.



Note You need to log in before you can comment on or make changes to this bug.