Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 446835 - pup tracebacks when retrieving updates from Satellite 4.2.2
Summary: pup tracebacks when retrieving updates from Satellite 4.2.2
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut
Version: 5.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
: 455658 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-16 11:55 UTC by Jan Hutař
Modified: 2013-03-12 20:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-12 20:11:29 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Hutař 2008-05-16 11:55:21 UTC
Description of problem:
pup tracebacks when retrieving updates on system registered to Satellite 4.2.2.


Version-Release number of selected component (if applicable):
Satellite 4.2.2 (rlx-1-14.rhndev.redhat.com)
yum-rhn-plugin-0.5.3-6.el5.noarch
pirut-1.2.10-1.el5.noarch or pirut-1.3.28-13.el5.noarch
  (tracebacks on both versions, so no regression in RHEL-5.1 -> 5.2)


How reproducible:
always


Steps to Reproduce:
1. wait for puplet to show updates available icon
2. click "Apply updates"


Actual results:
Component: pirut
Summary: TB429c5e45 rhnplugin.py:275:_getFile:RepoError: failed to retrieve 
repodata/updateinfo.xml.gz from rhel-i386-server-5
error was [Errno -1] Metadata file does not match checksum

Traceback (most recent call last):
  File "/usr/sbin/pup", line 617, in ?
    main()
  File "/usr/sbin/pup", line 613, in main
    pup.run()
  File "/usr/sbin/pup", line 451, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 291, in doRefresh
    self.populateUpdates()
  File "/usr/sbin/pup", line 347, in populateUpdates
    self.updateMetadata.add(repo)
  File "/usr/lib/python2.4/site-packages/yum/update_md.py", line 265, in add
    md = obj.retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 867, in 
retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/yum-plugins/rhnplugin.py", line 275, in _getFile
    raise yum.Errors.RepoError, \
RepoError: failed to retrieve repodata/updateinfo.xml.gz from rhel-i386-server-5
error was [Errno -1] Metadata file does not match checksum

Local variables in innermost frame:
e: [Errno -1] Metadata file does not match checksum
url: None
text: None
self: rhel-i386-server-5
cache: False
reget: None
relative: repodata/updateinfo.xml.gz
start: None
checkfunc: (<bound method RhnRepo.checkMD of <rhnplugin.RhnRepo object at 
0x9a45e4c>>, ('updateinfo',), {})
copy_local: 1
end: None
local: //var/cache/yum/rhel-i386-server-5/updateinfo.xml.gz


Expected results:
updates displayed


Additional info:
`yum upgrade` works perfectly

Running pup from terminal gives me:
$ pup
Loading "rhnplugin" plugin
no groups present!
...traceback as above...

Comment 1 James Antill 2008-07-16 21:03:40 UTC
*** Bug 455658 has been marked as a duplicate of this bug. ***

Comment 2 James Antill 2008-07-16 21:04:48 UTC
 Note that the only bug with pup here is that it doesn't display a better error
message ... what the traceback is saying is that the metadata is out of sync on
the server.


Comment 3 James Antill 2013-03-12 20:11:29 UTC
I think the RHN side of this has been fixed anyway, so hopefully it doesn't matter that we'll still traceback here.


Note You need to log in before you can comment on or make changes to this bug.