Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4467 - NFS and Network Appliance (NetApp) lose contact
Summary: NFS and Network Appliance (NetApp) lose contact
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-server
Version: 6.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-10 23:53 UTC by sandman
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-15 04:24:51 UTC


Attachments (Terms of Use)

Description sandman 1999-08-10 23:53:19 UTC
When running RedHat 6.0 and connecting to our Network
Applicance it occasionaly (at least once a day) lose sight
of the NFS mount.

This did not occur when using RedHat5.2.

Any Ideas?

Sandy

This is a dump from /var/log/message


Jul 26 21:08:04 hotweb005 kernel: nfs: server hotnetapp001
not responding, still tryi
ng
Jul 26 21:08:04 hotweb005 kernel: nfs: server hotnetapp001
not responding, still tryi
ng
Jul 26 21:08:06 hotweb005 kernel: nfs: task 43216 can't get
a request slot
Jul 26 21:08:06 hotweb005 kernel: nfs: task 43217 can't get
a request slot
Jul 26 21:08:06 hotweb005 kernel: nfs: task 43218 can't get
a request slot
Jul 26 21:08:06 hotweb005 kernel: nfs: task 43219 can't get
a request slot
Jul 26 21:08:06 hotweb005 kernel: nfs: task 43220 can't get
a request slot
Jul 26 21:08:06 hotweb005 kernel: nfs: task 43221 can't get
a request slot
Jul 26 21:08:16 hotweb005 kernel: nfs: task 43222 can't get
a request slot
Jul 26 21:08:25 hotweb005 kernel: nfs: task 43234 can't get
a request slot
Jul 26 21:08:34 hotweb005 kernel: nfs: task 43235 can't get
a request slot
Jul 26 21:08:57 hotweb005 kernel: nfs: task 43236 can't get
a request slot
Jul 26 21:09:00 hotweb005 kernel: nfs: server hotnetapp001
OK
Jul 26 21:09:06 hotweb005 last message repeated 11 times

Comment 1 Jeff Johnson 1999-08-12 15:43:59 UTC
What kernel and what knfsd are you running? You migh try the latest
kernel and knfsd from Raw Hide -- NFS has changed some from virgin
Red Hat 6.0 binaries ...

Comment 2 vijay 1999-08-17 17:40:59 UTC
Hi,
We downgraded to RH 5.2. However, to use 1G memory we need to upgrade
the kernel back to 2.2.5. The nfs-server version is 2.2beta37-1
We still experienced the same nfs errors. So looks like there is some
problem with the new 2.2.5 kernel. Any ideas?

Comment 3 vijay 1999-08-18 00:53:59 UTC
New results: We nfs mounted a 5.2 linux (2.2.5) machine
partition (/data1) to the 5.2 linux (2.0.6) machine as /data. We
loaded the cpu by doing a recursive copy of /usr to a /data/xyz.
We still get the errors:
Aug 17 05:45:14 hotweb006 kernel: NFS server hotweb001 not responding,
still try
ing.
Aug 17 05:45:14 hotweb006 kernel: NFS server hotweb001 OK.
Aug 17 05:48:18 hotweb006 kernel: NFS server hotweb001 not responding,
still try
ing.
Aug 17 05:48:18 hotweb006 kernel: NFS server hotweb001 OK.

You can easily reproduce this. I have not tried a 5.2(2.0.6) to
5.2(2.0.6) mount yet.

Comment 4 vijay 1999-08-18 22:57:59 UTC
Just tested 5.2 (2.0.6) with 5.2 (2.0.6) nfs mounts and the same error
occurs. However, in this case the erorr is for a split second only.

Comment 5 vancleef 2000-02-09 20:12:59 UTC
This problem has impacted our systems also.  When it strikes, all processes
using NFS files systems are effectively hung until whatever is happening runs
its course.

Feb  9 11:55:01 arwin kernel: NFS: server iris, readdir reply truncated
Feb  9 11:55:01 arwin kernel: NFS: nr=38, slots=3, len=7

I would like to see the priority on this bumped up a notch or two.


Note You need to log in before you can comment on or make changes to this bug.