Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 446513 - Installer crashes with JFS /home partition, file system tools not on live images (or in comps)
Summary: Installer crashes with JFS /home partition, file system tools not on live ima...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 9
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL: http://hyperfileshare.com/d/c53875e8
Whiteboard:
: 452436 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-14 21:54 UTC by Łukasz Roś
Modified: 2013-01-10 04:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-24 13:47:20 UTC


Attachments (Terms of Use)
Bugtrace from anaconda (deleted)
2008-05-14 21:55 UTC, Łukasz Roś
no flags Details

Description Łukasz Roś 2008-05-14 21:54:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/4.0; Linux) KHTML/4.0.3 (like Gecko) Fedora/4.0.3-7.fc9

Description of problem:
During installation of KDE Live i686 version of Fedora 9, every time after
choosing my existing /home partition (JFS), installer crashes and gives out a
bug trace code

Version-Release number of selected component (if applicable):
anaconda-11.4.0.82-1.i386

How reproducible:
Always


Steps to Reproduce:
1. During installation of live KDE i686 CD choose 'create custom layout'
option
2. Choose existing /home parition with JFS as /home for fedora
3. Agree on formatting root partition

Actual Results:
Window 'Exception occurred' appears and gives a possibility to save bugtrace

Expected Results:
Fedora should install on formatted root partition and use my old /home
partition with JFS filesystem (ar, at least, inform me, that JFS is not
supported and I need to choose another filesystem for /home partition)

Additional info:
I posted bugtrace generated by anaconda on
http://hyperfileshare.com/d/c53875e8

Comment 1 Łukasz Roś 2008-05-14 21:55:43 UTC
Created attachment 305408 [details]
Bugtrace from anaconda

Comment 2 Chris Lumens 2008-05-15 04:03:09 UTC
Jesse - this sounds like the jfsutils package isn't getting included for
anaconda to pull jfs_tune from when we're making the stage2 image.  Thoughts?

Comment 3 Jesse Keating 2008-05-15 15:29:55 UTC
The compose manifest has:

# filesystem stuff
reiserfs-utils
xfsprogs
jfsutils

The compose log also shows that jfsutils is found and brought in, and also
installed during buildinstall.

However since the original poster was talking about install from /live/, then
that's not pungi land, that's livecd-creator land.  And since it's KDE, that's Rex.

Comment 4 Rex Dieter 2008-05-15 15:37:46 UTC
none of those are referenced directly in any of the livecd setups, but these
*are* included (from fedora-livecd-9-base.ks):
@base-x
@base
@core
@fonts
@admin-tools
@dial-up
@hardware-support
@printing


now to check comps to see if those utils are in any of these groups... in @base,
but listed as optional (ouch).

End result: these aren't on any of the fedora livecd's.


Comment 5 Rex Dieter 2008-05-15 15:59:20 UTC
My recommendation:
reiserfs-utils
xfsprogs
jfsutils

get pulled in somehow, whether that is anaconda Requires or making these default
items in @base, or added to fedora-livecd-9-base.ks or whatever.

Comment 6 Chris Lumens 2008-06-23 18:10:15 UTC
*** Bug 452436 has been marked as a duplicate of this bug. ***

Comment 7 Jesse Keating 2008-06-23 18:34:58 UTC
These aren't put in because of the space requirements.  That's the nature of
trying to fit things on a CD.  The bug here is that anaconda doesn't/didn't
detect the lack of these tools when offering you the ability to use them for
your partition.

Comment 8 Rex Dieter 2008-06-23 18:48:41 UTC
ah, gotcha, reassigning back to anaconda d00dz.

Comment 9 Petr Machata 2008-06-24 08:35:47 UTC
(In reply to comment #7)
> The bug here is that anaconda doesn't/didn't detect the lack of these tools 
> when offering you the ability to use them for your partition.

I'd also like to point out that anaconda tried to use these tools even though I
asked it not to touch my reiserfs partition (as mentioned in bug 452436).



Comment 10 Chris Lumens 2008-07-24 13:47:20 UTC
We've been detecting that filesystems aren't supported if the required utilities
aren't around for a little while now, so I think this one can be closed.


Note You need to log in before you can comment on or make changes to this bug.