Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 446322 - KDE Menu icon draws out of bounds
Summary: KDE Menu icon draws out of bounds
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase-workspace
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 453878 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-14 03:09 UTC by Peter Fernandes
Modified: 2008-07-03 00:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-14 23:56:11 UTC


Attachments (Terms of Use)
Screen shot (deleted)
2008-05-14 03:09 UTC, Peter Fernandes
no flags Details
Screen Shot Tiny to normal (deleted)
2008-05-14 16:02 UTC, Steven M. Parrish
no flags Details


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 162111 None None None Never

Description Peter Fernandes 2008-05-14 03:09:46 UTC
Description of problem:
After changing the taskbar size to "tiny," the KDE menu icon (Fedora logo)
didn't scale down, so the part that is drawn off the screen appears at the top
of the screen (see screenshot).  When clicked, the menu appears near the top of
the screen close to the bottom part (the out-of-bounds part) of the icon.

Version-Release number of selected component (if applicable):

kdebase-workspace-4.0.3-20.fc9

How reproducible:

Every startup

Steps to Reproduce:
1.Change taskbar size from the default setting to "Tiny" in "Panel Settings."

  
Actual results:

The icon is drawn at the incorrect size, out of screen bounds and appearing
partially at the top of the screen.  The KMenu also appears at the top of the
screen.

Expected results:
A smaller KMenu icon is drawn; the Kmenu appears near the bottom of the screen.

Comment 1 Peter Fernandes 2008-05-14 03:09:46 UTC
Created attachment 305324 [details]
Screen shot

Comment 2 Steven M. Parrish 2008-05-14 16:02:19 UTC
Created attachment 305376 [details]
Screen Shot   Tiny to normal

Comment 3 Steven M. Parrish 2008-05-14 16:09:06 UTC
Confirmed here.  Also see the screen shot I posted in Comment #2.  Going from
tiny back to normal results in the taskbar not going back to where it should and
the screen wrapping from the top to the bottom

Comment 4 Rex Dieter 2008-05-14 16:09:53 UTC
Upstream please, bugs.kde.org.  Not much we can do locally in fedora-land.

Comment 5 Steven M. Parrish 2008-05-14 16:46:56 UTC
Peter Fernandes please file upstream. and add info to this report.

Since what I reported is really a separate bug I filed it upstream.
http://bugs.kde.org/show_bug.cgi?id=162098.



Comment 6 Peter Fernandes 2008-05-14 23:54:55 UTC
This bug has been closed: moved to http://bugs.kde.org/show_bug.cgi?id=162111

Comment 7 Kevin Kofler 2008-07-03 00:01:31 UTC
*** Bug 453878 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.