Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 445506 - network configuration ignored after installation
Summary: network configuration ignored after installation
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-07 10:16 UTC by Luciano Rocha
Modified: 2009-02-16 20:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-16 20:32:10 UTC


Attachments (Terms of Use)
anaconda install error (deleted)
2008-05-12 11:00 UTC, Luciano Rocha
no flags Details

Description Luciano Rocha 2008-05-07 10:16:21 UTC
Description of problem:
While installing Fedora 9 Preview, using net/http install, I was asked about my
network configuration (IP addresses, netmasks, hostname, gateway).

I configured a static IP address, but after booting, I found that my
configuration was completely ignored.

I noticed NetworkManager running, and I stopped it. After a reboot, I had no
network, as the init script wasn't set for starting on boot. Fixed the problem,
rebooted, and all was ok.

If I'm asked for network configuration when installing, it should be saved and
used, not ignored.

Note that I'm talking about the configuration of the interfaces. The
installation was made with "ip=dhcp noipv6 ksdevice=link", so the configuration
I entered wasn't for the installation proper.

Version-Release number of selected component (if applicable):
Fedora 9 preview.

How reproducible:
Only installed once.

Steps to Reproduce:
1. When installing, enter a static IP address for a network interface;
2. After installation, check if network is correctly configured with the defined
IP address.
  
Additional info:

My machine has two network interfaces, and the dhcp configuration has only the
mac-address for the now disconnected interface. So it is giving me a dynamic
address, but I have one static assigned.

The generated anaconda-ks.cfg file has:
network --device eth0 --onboot no --bootproto dhcp --hostname xxx
network --device eth1 --bootproto static --ip yyy.zzz --netmask 255.255.255.0
--gateway yyy.1 --nameserver yyy.2,yyy.1 --hostname xxx

Comment 1 Bill Nottingham 2008-05-07 17:02:13 UTC
Please try upgrading/installing from rawhide - a few bugs were fixed in exactly
this area.

Comment 2 Luciano Rocha 2008-05-12 10:59:25 UTC
(In reply to comment #1)
> Please try upgrading/installing from rawhide - a few bugs were fixed in exactly
> this area.

I can't install from current rawhide. Just made a sync with
download.fedora.redhat.com, and I get the error in the picture that follows.

Comment 3 Luciano Rocha 2008-05-12 11:00:14 UTC
Created attachment 305116 [details]
anaconda install error

Comment 4 Bug Zapper 2008-05-14 10:45:29 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Chris Lumens 2008-05-15 04:37:40 UTC
That's a totally different bug from your original report.  Please file a
separate bug for that if you are still seeing it.  Closing this one out on the
basis of comment #1.

Comment 6 Luciano Rocha 2008-06-09 13:39:36 UTC
I've just reinstalled Fedora 9. Same problem.
/etc/sysconfig/network-scripts/ifcfg-eth0 created with the configuration that I
created in the installer, but completely ignored.

Comment 7 Chris Lumens 2008-06-09 14:14:39 UTC
Do you have both the network and NetworkManager services enabled?  (chkconfig
<service name> --list)

Comment 8 Luciano Rocha 2008-06-09 15:17:01 UTC
(In reply to comment #7)
> Do you have both the network and NetworkManager services enabled?  (chkconfig
> <service name> --list)

It was a complete re-install, so the services were as the installation made them be.

The network service was disabled, and NetworkManagar was enabled and running.

I turned off NetworkManager and switched to "network", and now my network
configuration comes ok.


Comment 9 A.J. Werkman 2008-06-28 11:17:17 UTC
I reproduced this bug in rawhide with anaconda 11.4.1.9.

I install rawhide with a static IPv4 addressing scheme. After the first boot I
see NetworkManager active and network not active. Due to this there is a
dhcpclient active for the interface defined static. So it has the DHCP address
not the static IP address.

Stopping NetworkManager and starting network changes things as I expect them to be.

Comment 10 Chris Lumens 2008-08-28 20:40:35 UTC
Please give F10 beta a try when it is released.  We've got a whole lot of new networking code that should fix up lots of issues like this one.  Feel free to move out of MODIFIED if you see this is still a problem.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.