Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 444589 - xentop - incompatibility between HV and userspace toolset
Summary: xentop - incompatibility between HV and userspace toolset
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen
Version: 5.2
Hardware: ia64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Tetsu Yamamoto
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks: 448899
TreeView+ depends on / blocked
 
Reported: 2008-04-29 12:09 UTC by Adam Stokes
Modified: 2018-10-20 01:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 20:05:12 UTC


Attachments (Terms of Use)
Patch to add sysctl version check for physinfo in kernel (deleted)
2008-07-21 14:23 UTC, Tetsu Yamamoto
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2009:0225 normal SHIPPED_LIVE Important: Red Hat Enterprise Linux 5.3 kernel security and bug fix update 2009-01-20 16:06:24 UTC

Description Adam Stokes 2008-04-29 12:09:18 UTC
Description of problem:
So far on ia64 only xentop shows following warning message.
==
sysctl operation failed -- need to rebuild the user-space tool set?
==

Version-Release number of selected component (if applicable):
xen 3.0.x

How reproducible:
100%

Steps to Reproduce:
1.#xentop -b -i 2 -d 1
2.
3.
  
Actual results:
sysctl operation failed -- need to rebuild the user-space tool set?

Expected results:
No warning

Additional info:
This incident happens primarily due to the updates provided to the HV in 5.2

Comment 2 RHEL Product and Program Management 2008-04-29 12:14:42 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 4 Itamar Reis Peixoto 2008-05-16 02:38:39 UTC
I am using 

xen-libs-3.1.2-2.fc8
kernel-xen-2.6.21.7-3.fc8
xen-3.1.2-2.fc8


and xentop is showing NETTX(k)  NETRX(k) at fixed value 0

example
 NETTX(k)  NETRX(k) 
   0          0 



Comment 8 Daniel Berrange 2008-07-21 11:04:59 UTC
Please attach the proposed patch when switching to POST state.


Comment 9 Tetsu Yamamoto 2008-07-21 14:23:16 UTC
Created attachment 312260 [details]
Patch to add sysctl version check for physinfo in kernel

Comment 10 Tetsu Yamamoto 2008-07-21 14:24:31 UTC
Interface version check between HV and userspace was modified in RHEL5.2
to allow through physinfo calls with newer versions for NUMA extensions.
 HV and tools have the modification, but kernel does not have it which
is needed for xen/ia64.  The attached patch on comment #9 adds it in kernel.

Comment 11 Daniel Berrange 2008-07-21 14:26:37 UTC
Ok, this isn't a userspace bug then - switching to kernel-xen instead.


Comment 12 Don Zickus 2008-07-25 20:26:46 UTC
in kernel-2.6.18-100.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 19 errata-xmlrpc 2009-01-20 20:05:12 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2009-0225.html


Note You need to log in before you can comment on or make changes to this bug.