Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 443661 - I believe nss_ldap is leaking a file descriptor
Summary: I believe nss_ldap is leaking a file descriptor
Keywords:
Status: CLOSED DUPLICATE of bug 445584
Alias: None
Product: Fedora
Classification: Fedora
Component: nss_ldap
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 451820 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-22 18:36 UTC by Daniel Walsh
Modified: 2009-01-27 23:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-27 23:23:46 UTC


Attachments (Terms of Use)

Description Daniel Walsh 2008-04-22 18:36:22 UTC
Description of problem:
I am seeing leaked file descriptors from crond_t 
#============= certwatch_t ==============
allow certwatch_t crond_t:tcp_socket { read write };

#============= httpd_t ==============
allow httpd_t crond_t:tcp_socket { read write };

#============= locate_t ==============
allow locate_t crond_t:tcp_socket { read write };

#============= logrotate_t ==============
allow logrotate_t crond_t:tcp_socket { read write };

#============= logwatch_t ==============
allow logwatch_t crond_t:tcp_socket { read write };

I have just hooked up nss_ldap and now am seeing processes trying to access
tcp_socket.

Comment 1 Bug Zapper 2008-05-14 09:57:28 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Daniel Walsh 2008-06-23 10:09:08 UTC
*** Bug 451820 has been marked as a duplicate of this bug. ***

Comment 3 Nalin Dahyabhai 2009-01-27 23:23:46 UTC

*** This bug has been marked as a duplicate of bug 445584 ***


Note You need to log in before you can comment on or make changes to this bug.