Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4431 - Incorrect handling of non-aliased interfaces (lo and eth)
Summary: Incorrect handling of non-aliased interfaces (lo and eth)
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-08 23:40 UTC by hhaygood
Modified: 2017-05-19 00:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-09 15:03:00 UTC


Attachments (Terms of Use)

Description hhaygood 1999-08-08 23:40:50 UTC
System is stock RHL6.0/Intel.  Noticed problem after
building 2.2.10 from pristine source, don't know if it's
related.

/etc/sysconfig/network-scripts/ifup-post, lines 20-22 read:

if [ "$ISALIAS" = no ] ; then
    /etc/sysconfig/network-scripts/ifup-aliases ${DEVICE}
fi

Thus, it's trying to bring up alias interfaces when it
explicitly knows that there are none.  Only effect on my
system is to cause modprobe errors ("modprobe: can't locate
module eth0:0" [to eth0:49]),
but I suspect that this will cause fairly major hassles for
those who do use alias interfaces.  (The converse of the
effect that I see is that interfaces that include aliases
will not be properly brought up.)

Simple fix is to replace "no" with "yes" on line 20.  It
appears to work just fine for me, and makes sense logically.

Hal Haygood, RHCE
hhaygood@earthlink.net

Comment 1 Bill Nottingham 1999-08-09 15:01:59 UTC
That's not how it works. The 'ISALIAS' checks to see whether
the current interface is an alias; because you don't want
to bring up interfaces for an alias.

The problem is that you compiled the kernel without aliasing
support, and linuxconf's behaviour in this case is not very
good (it's what's causing these messages). Either comment
out the portion of ifup-aliases that refers to linuxconf, or
upgrade to the latest initscripts in Raw Hide, which has this
already done.

Comment 2 openshift-github-bot 2017-05-19 00:50:04 UTC
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/a4b686c5e71e8860390ab4dd206e2cf2283087bc
Merge pull request #4438 from bfallonf/supported_4431

Issue 4431 Added supported integrations Q to planning


Note You need to log in before you can comment on or make changes to this bug.