Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4429 - TCSH history doesn't work on a Alpha DP264.
Summary: TCSH history doesn't work on a Alpha DP264.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcsh
Version: 6.0
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-08 21:57 UTC by niles
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-10 20:16:53 UTC


Attachments (Terms of Use)

Description niles 1999-08-08 21:57:57 UTC
tcsh history is broken. Even if I do "source -h .cshrc" the
history will still be blank with "set history=1000", If I
"set history=10" it will remember what I "source -h" but not
any commands I type.  bash works perfect.

I believe this is a 21264 specific problem as it does not
occur on my 21064.  It may even be a SMP 21264 unique
problem.  I've also tried rebuilding tcsh from SRPM using
the patched egcs compiler to no avail.

Comment 1 niles 1999-08-22 14:00:59 UTC
The fact that history didn't work at all was because of bug #3686.
It was the bugs in the kde scripts (kdesupport).  After applying
fixes for bug #3686 history works for the current session.

However, I do notice that history is still not preserved between
sessions.  It this just a configuration change?

Comment 2 Preston Brown 1999-08-23 15:32:59 UTC
do you have a ~/.history file?

Comment 3 niles 1999-08-24 01:45:59 UTC
I had to add both a ~/.history file and "set savehist=1" to get
it to work between sessions.  I've never had to do this under
Redhat/i386.  Funny...oh well. Thanks!

Comment 4 Jeff Johnson 2000-01-10 20:16:59 UTC
This problem appears to be reolved. Please reopen if I'm wriong.


Note You need to log in before you can comment on or make changes to this bug.