Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4423 - glibc-2.1.2-3: Expat in Mozilla won't compile with -O
Summary: glibc-2.1.2-3: Expat in Mozilla won't compile with -O
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc
Version: 1.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-08 04:39 UTC by Brian Ryner
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-11 01:52:19 UTC


Attachments (Terms of Use)

Description Brian Ryner 1999-08-08 04:39:20 UTC
With glibc-2.1.2-3, expat in Mozilla chokes when trying to
compile with -O.  I haven't extensively analyzed it, but it
looks like it might be a problem with a macro definition of
memset().

This is with the current Mozilla code from CVS, configured
with --enable-optimize.

Comment 1 Brian Ryner 1999-08-08 06:19:59 UTC
I think my original guess that this is a memset() problem might be
wrong.  If you remove the line:

#define int int32

in expat/xmltok/xmldef.h, the problem goes away.  Of course this
doesn't guarantee a 32-bit integer, so it's not a real solution.

Comment 2 Brian Ryner 1999-08-09 20:07:59 UTC
A workaround is being checked in for mozilla.  However, we don't yet
know the real reason that the original code did not work, and why it
only breaks with -O.

Also, it is possible that this is an egcs problem.  I'm using
egcs-1.1.2-17 from Rawhide.

Comment 3 Cristian Gafton 1999-08-11 01:52:59 UTC
I am not sure where the problem is - please reopen the bug if you can
isolate the problem further.


Note You need to log in before you can comment on or make changes to this bug.