Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 441209 - [stardict] Adjust default dictionary selections when locale is changed.
Summary: [stardict] Adjust default dictionary selections when locale is changed.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: stardict
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Caius Chance
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 453571 (view as bug list)
Depends On:
Blocks: 453571
TreeView+ depends on / blocked
 
Reported: 2008-04-07 06:42 UTC by Caius Chance
Modified: 2008-08-04 23:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-04 06:07:33 UTC


Attachments (Terms of Use)
Patch (deleted)
2008-08-04 06:17 UTC, Caius Chance
no flags Details

Description Caius Chance 2008-04-07 06:42:49 UTC
Description of problem:
All dictionary are selected by default, which may be excessive to users.

Version-Release number of selected component (if applicable):
stardict-dic-zh_CN-2.4.2-3.fc8.noarch
stardict-3.0.1-8.fc9.i386
stardict-dic-zh_TW-2.4.2-3.fc8.noarch

How reproducible:
Always.


Steps to Reproduce:
1. Install above packages.
2. Boot into gnome.
3. Start stardict.
4. Go to dictionary setting window of stardict.
5. Check results.
  
Actual results:
All dictionaries are selected.

Expected results:
Appropriate selection of dictionaries are used by default.

Additional info:
Could notify users that they could customize the selections in setting window.

Comment 1 Hu Zheng 2008-04-07 07:04:27 UTC
StarDict program have no information of which dictionary will be installed at
all. There are 2000 dictionaries, and it is hard to determine which one is
suitable for which locale.
Yes, stardict need to be customized by the user him/herself. And, stardict is
designed for advance users at the beginning, who can find the dict manage window
and use it.

Any way, you can send me the patch.

Comment 2 Caius Chance 2008-04-07 07:10:06 UTC
At least zh_TW shouldn't have zh_CN dictionaries selected by default and vice versa?

Let's try to make it also usable for novice users.

Comment 3 Hu Zheng 2008-04-07 10:06:48 UTC
Nice, welcome to join stardict development and make it usable for novice! In
fact, this is just the weakness of me, I can make stardict satisfy every expert,
then novice even don't know how to use and setup it!

svn co https://stardict.svn.sourceforge.net/svnroot/stardict/trunk stardict

I suppose we popup a window for default setting for different level people, and
a teaching guide window.

Very happy that you can join and make stardict easy to use!

Comment 4 Bug Zapper 2008-05-14 09:00:53 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Caius Chance 2008-08-04 06:07:33 UTC
Patched and built:

http://koji.fedoraproject.org/koji/buildinfo?buildID=58477

Currently the "defaultdict.cfg" needs population for different locales.

Comment 6 Caius Chance 2008-08-04 06:17:01 UTC
Created attachment 313309 [details]
Patch

Since I got no idea on WIN32 implementation, I am sending this patch file to upstream as idea and leave that to him.

Comment 7 Caius Chance 2008-08-04 23:31:40 UTC
*** Bug 453571 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.