Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4395 - gprof still crashes with egcs g77 output
Summary: gprof still crashes with egcs g77 output
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: binutils
Version: 6.0
Hardware: alpha
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-06 15:49 UTC by niles
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-27 16:30:25 UTC


Attachments (Terms of Use)

Description niles 1999-08-06 15:49:25 UTC
With obvious similarity with Bug #3971...

Even after upgrading all the egcs-1.1.2-17 packages
with contained Jeff Law's patches...

gprof will core dump on ANY g77 compiled FORTRAN.
Try:
cat "         END" > tmp.f
g77 -pg tmp.f
gprof
Segmentation fault (core dumped)

After reading Bug #3971 I'm assuming it's an egcs
problem, but it could be in gprof itself (binutils).

Comment 1 Jim Kingdon 1999-08-08 13:08:59 UTC
One needs to compile gprof (binutils) with egcs 1.1.2-17.
Or in other words, it doesn't matter (for this bug) what
your program is compiled with, just what gprof was compiled
with.
As far as I know, we haven't made a fixed binutils package yet.

Comment 2 niles 1999-08-08 21:47:59 UTC
Agreed, once I re-built the binutils package using the new
egcs; gprof started worked fine.  So probably mark this as
a duplicate of Bug #3971 and close it.  But, you really should
release a new binary of binutils.

Comment 3 Jim Kingdon 1999-08-27 16:30:59 UTC
Please try binutils-2.9.1.0.23-2 which should be in the next Rawhide
release.

Comment 4 Jim Kingdon 1999-08-30 17:45:59 UTC
Correction, the fixed binutils package is binutils-2.9.1.0.23-5.


Note You need to log in before you can comment on or make changes to this bug.