Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 438857 - Update to Mercurial 1.0 - some packaging fixes
Summary: Update to Mercurial 1.0 - some packaging fixes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mercurial
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Neal Becker
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 438913 (view as bug list)
Depends On: 235437
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-25 17:02 UTC by Stephen
Modified: 2008-08-05 20:06 UTC (History)
4 users (show)

Fixed In Version: f9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-05 20:06:58 UTC


Attachments (Terms of Use)
emacs site start file for hg and mq (deleted)
2008-03-25 20:18 UTC, Stephen
no flags Details

Description Stephen 2008-03-25 17:02:25 UTC
Currently available Mercurial package is 0.95. 0.96 was released but is not
available in Fedora.

Current upstream release is 1.0 and it would be great if this could be pushed in
time for F9.


Couple of fixes:

- The current spec installs mercurial.el. It should also install mq.el. It would
be nice if this was in the separate package emacs-mercurial. It would also be
nice if this package could drop an init file into
site-lisp/site-start.d/mercurial-init.el. See: emacs-git rpm for an example.

- hgk should be split into it's own package and a dependency on Tk added.

Comment 1 Neal Becker 2008-03-25 17:21:24 UTC
(In reply to comment #0)
> Currently available Mercurial package is 0.95. 0.96 was released but is not
> available in Fedora.
> 
> Current upstream release is 1.0 and it would be great if this could be 
pushed in
> time for F9.
> 
> 
> Couple of fixes:
> 
> - The current spec installs mercurial.el. It should also install mq.el. 

OK.

It would
> be nice if this was in the separate package emacs-mercurial.

OK, but not sure about how to transition from mercurial providing mercurial.el 
to the new pkg providing it.

 It would also be
> nice if this package could drop an init file into
> site-lisp/site-start.d/mercurial-init.el. See: emacs-git rpm for an example.
OK

> - hgk should be split into it's own package and a dependency on Tk added.

I tried adding %check and found that at least 1 test is failing - I wanted to 
get this resolved upstream before updating to 1.0.



Comment 2 Neal Becker 2008-03-25 18:12:02 UTC
What would you want to go into site-lisp/site-start.d/mercurial-init.el?

Comment 3 Stephen 2008-03-25 18:16:18 UTC
> > It would be nice if this was in the separate
> > package emacs-mercurial.
>
> OK, but not sure about how to transition from mercurial
> providing mercurial.el to the new pkg providing it.

I think in this case nothing special needs to happen. Folks wanting
emacs-mercurial will explicitly install it.


> > - hgk should be split into it's own package and a dependency on Tk added.
>
> I tried adding %check and found that at least 1 test is
> failing - I wanted to get this resolved upstream before updating to 1.0.

You mean run the test suite?  It takes ~ 10-20 minutes to run (lots of calls to
sleep(), server starts and binds ports)...


btw, the 0.95 package (and a 0.96 package I found somewhere in koji I think) fail:

$ hgk
Error in startup script: can't read "env(HG)": no such variable
    while executing
"exec $env(HG) debug-config"
    (procedure "getconfig" line 4)
    invoked from within
"getconfig"
    invoked from within
"array set config [getconfig]"
    (file "/usr/bin/hgk" line 3881)


'hg view' however does work (if the extension is enabled). Not sure what the
upstream recommended way of invoking this is.


Comment 4 Stephen 2008-03-25 20:18:15 UTC
Created attachment 299066 [details]
emacs site start file for hg and mq

I've just upgraded to emacs-23 from cvs and I'm getting the error:

  Wrong type argument: commandp, hg-mode

when running 'hg-mode', so someone should double-check that this works with
Fedora default emacs.

Comment 5 Neal Becker 2008-03-26 00:30:14 UTC
(In reply to comment #4)
> Created an attachment (id=299066) [edit]
> emacs site start file for hg and mq
> 
> I've just upgraded to emacs-23 from cvs and I'm getting the error:
> 
>   Wrong type argument: commandp, hg-mode
> 
> when running 'hg-mode', so someone should double-check that this works with
> Fedora default emacs.

M-x load-lib mercurial
Then visit hg controlled file.
Seems to be working for me with emacs-23.0.60.1


Comment 6 Stephen 2008-03-27 20:51:53 UTC
Actually, works for me too -- my .emacs needed a clean up.


Comment 7 Jonathan Underwood 2008-04-05 00:32:03 UTC
*** Bug 438913 has been marked as a duplicate of this bug. ***

Comment 8 Bug Zapper 2008-05-14 06:50:14 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.