Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4385 - status function from initscripts returns wrong answers
Summary: status function from initscripts returns wrong answers
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-06 00:51 UTC by michal
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-06 14:04:36 UTC


Attachments (Terms of Use)

Description michal 1999-08-06 00:51:18 UTC
There is a bug in status() from /etc/rc.d/init.d/functions
with such long standing that it probably aquired already
a position of a "feature". Status querries from various
scripts which use this function always return "running"
with ridiculous process id's.  This is a result of an
incorrect filtering when looking for pid with a help
of 'ps auxww'.

A trivial patch is mailed separately to avoid mangling by
HTML

Comment 1 Bill Nottingham 1999-08-06 14:04:59 UTC
fixed (albeit differently) in the latest initscripts in Raw hide.


Note You need to log in before you can comment on or make changes to this bug.