Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4382 - sendmail has file locking problems -- needs to be recompiled with new libraries
Summary: sendmail has file locking problems -- needs to be recompiled with new libraries
Keywords:
Status: CLOSED DUPLICATE of bug 4272
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-05 21:16 UTC by tpavlic
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-31 23:34:04 UTC


Attachments (Terms of Use)

Description tpavlic 1999-08-05 21:16:12 UTC
sendmail looks to have been compiled using the old file
locking emulation from the old pre-2.2.x libraries. 2.2.x
(2.1.x+) have completely gotten rid of the old file locking
emulation and now use real BSD file locking. Because of
this, sendmail (and any other program compiled with the old
routines) will not be able to get any locks on an NFS
share.

Please recompile sendmail with the new libraries. rpm and
elm are two other examples of this same problem.

Comment 1 Jeff Johnson 1999-08-31 23:34:59 UTC
Sendmail has been recompiled, but I suspect the problem lies elsewhere
(knfsd?). I coalescing this problem with elm


*** This bug has been marked as a duplicate of 4272 ***


Note You need to log in before you can comment on or make changes to this bug.