Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 435526 - patch resets SELinux contexts
Summary: patch resets SELinux contexts
Keywords:
Status: CLOSED DUPLICATE of bug 229329
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: patch
Version: 5.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Tim Waugh
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-29 22:48 UTC by Max Kanat-Alexander
Modified: 2008-06-16 09:21 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-16 09:21:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Max Kanat-Alexander 2008-02-29 22:48:33 UTC
Whenever I use patch, it resets the contexts of all the files it touches to 
user_u:object_r:tmp_t:s0. I'm using it by applying a diff from stdin, if that
makes a difference.

This is particularly difficult since it resets the contexts even when you're a
non-root user, but restorecon is only in root's path.

Comment 1 Max Kanat-Alexander 2008-02-29 22:49:23 UTC
Oh, by the way, I think patch in more recent versions of Fedora doesn't do
this--it's only been happening to me in RHEL 5 (and in RHEL 4 before that).

Comment 3 Tim Waugh 2008-06-16 09:21:47 UTC

*** This bug has been marked as a duplicate of 229329 ***


Note You need to log in before you can comment on or make changes to this bug.