Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4351 - bad file /etc/profile.d/kde.csh -- not csh script
Summary: bad file /etc/profile.d/kde.csh -- not csh script
Keywords:
Status: CLOSED DUPLICATE of bug 3686
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdesupport
Version: 6.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-04 15:45 UTC by mbw8
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-04 16:34:13 UTC


Attachments (Terms of Use)

Description mbw8 1999-08-04 15:45:09 UTC
The upgraded 1.1.1 kdesupport from ftp.updates.com for
rh6.0  has a buggy file /etc/profile.d/kde.csh

It causes users with the CSH shell and sourcing the system
defaults to stop.

It is caused by this file using bash syntax, not csh syntax.

Here is a fixed version:

# KDE initialization script (csh)
#echo "CSH kde init script"
if ( $?KDEDIR ) then
         if ( $KDEDIR == "/usr" ) then
         exit
         endif
endif
setenv KDEDIR /usr
setenv kdepath "${KDEDIR}/bin"
echo $PATH | grep -q $kdepath
if ( $status ) then
  exit
endif

setenv PATH "${kdepath}:${PATH}"

Comment 1 Jeff Johnson 1999-08-04 16:34:59 UTC
*** This bug has been marked as a duplicate of 3686 ***


Note You need to log in before you can comment on or make changes to this bug.