Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 435029 - Data corruption with the 3w-xxxx driver on a 3ware 7000 or 8000 series card and >2GB of RAM
Summary: Data corruption with the 3w-xxxx driver on a 3ware 7000 or 8000 series card a...
Keywords:
Status: CLOSED DUPLICATE of bug 451945
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.1
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Tomas Henzl
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-26 21:51 UTC by Jeroen Wunnink
Modified: 2008-06-18 10:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-18 10:13:58 UTC


Attachments (Terms of Use)

Description Jeroen Wunnink 2008-02-26 21:51:42 UTC
Description of problem:
Random data corruption will occur with the stock 3w-xxxx driver on RHEL 5 x86_64
 when a system has more then 2GB of RAM installed

Reference KB issue at 3ware site:
----
http://www.3ware.com/KB/article.aspx?id=15243&cNode=6I1C6S [^]

If you have an Intel 64-bit EM64T system with 4 GB or more of system RAM, then
you should not use the 7000/8000 series in kernel driver 3w-xxxx if you are
using Linux kernels 2.6.15 through 2.6.22.

Instead you should use the driver source from this KB article to compile a new
driver.

You can still install Linux by specifying mem=2048M, then update the driver
after you install.

3ware 9000 series controllers are not affected by this issue.
-------

Version-Release number of selected component (if applicable):
1.26.02.001

How reproducible:
Big inserts into MySQL, download big files with wget (md5 corruption will
occur), compiles fail at random

Steps to Reproduce:
1. download a big file (rpm, tar.gz)
2. try to install it or unpack it
3. it may or may not be corrupt, rinse and repeat a few times for it to occur 

Same steps above when compiling bigger packages like php5 or apache2, it'll kick
out with a random error, a lot of times something like:

main/: file not recognized: Is a directory
collect2: ld returned 1 exit status
make: *** [libphp5.la] Error 1

And then after 3 or 4 more make clean and make attempts it compiles properly

Actual results:
md5 hash failures, compile errors, crashed mysql tables

Expected results:
none of the above

Additional info:
The new 3ware driver seems to fix it (to be found at above KB article at 3ware site)

New driver:
[root@shell test]# modinfo 3w-xxxx
filename:       /lib/modules/2.6.18-53.1.13.el5xen/kernel/drivers/scsi/3w-xxxx.ko
version:        1.26.03.000-2.6.18
license:        GPL
description:    3ware Storage Controller Linux Driver
author:         AMCC
srcversion:     B64D36FA9760E90E0F5A538
alias:          pci:v000013C1d00001001sv*sd*bc*sc*i*
alias:          pci:v000013C1d00001000sv*sd*bc*sc*i*
depends:        scsi_mod
vermagic:       2.6.18-53.1.13.el5xen SMP mod_unload gcc-4.1


Old driver:
[root@shell test]# modinfo
/lib/modules/2.6.18-53.1.13.el5xen/kernel/drivers/scsi/3w-xxxx.ko.old 
filename:      
/lib/modules/2.6.18-53.1.13.el5xen/kernel/drivers/scsi/3w-xxxx.ko.old
version:        1.26.02.001
license:        GPL
description:    3ware Storage Controller Linux Driver
author:         AMCC
srcversion:     3F506C6CE1CD3C5858E2583
alias:          pci:v000013C1d00001001sv*sd*bc*sc*i*
alias:          pci:v000013C1d00001000sv*sd*bc*sc*i*
depends:        scsi_mod
vermagic:       2.6.18-53.1.13.el5xen SMP mod_unload gcc-4.1
module_sig:
883f35047b1ec24c03ff3a61aa023c311265380a0b6a79772f1a4527d4933af4ea2552a5e3b0f49409f7ba13c2ce939fd7f380786e8747ec1e9f42c0e5

Comment 1 Jeroen Wunnink 2008-03-01 11:29:46 UTC
4 days since I updated the driver and the corruption hasn't occured anymore

Comment 2 Tomas Henzl 2008-06-18 10:13:58 UTC
This will be solved by an version update (BZ#451945), so I'm closing it here now.

*** This bug has been marked as a duplicate of 451945 ***


Note You need to log in before you can comment on or make changes to this bug.