Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4350 - Unmapped ioctl's in arch/sparc64/kernel/ioctl32.c
Summary: Unmapped ioctl's in arch/sparc64/kernel/ioctl32.c
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel
Version: 1.0
Hardware: sparc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
: 4308 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-04 15:34 UTC by Jeff Johnson
Modified: 2008-08-01 16:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Jeff Johnson 1999-08-04 15:34:07 UTC
(I've made the summary generic so that I have a place to
hang any/all of these problems).

A quick "grep SIOC /usr/include/*/*.h" with editing to
remove SIOC* ioctls will be attached. I'll be happy to help
map the amatuer radio glop :-)

Meanwhile a user would like
	SIOCADDTUNNEL
	SIOCCHGTUNNEL
	SIOCDELTUNNEL
	SIOCGETTUNNEL
added so that he can use iptunnel on an ultra.

Comment 1 Cristian Gafton 1999-08-16 19:09:59 UTC
Davem or JJ, please bless us with a comment here

Comment 2 Jeff Johnson 1999-08-23 18:20:59 UTC
*** Bug 4308 has been marked as a duplicate of this bug. ***

iptunnel does work on my intel platform but does not on my
Ultra1 sparc64 machine.
It gives me the following message:

[root@paul /root]# insmod ipip
[root@paul /root]# iptunnel
tunl0: ip/ip  remote any  local any  ttl inherit  nopmtudisc
[root@paul /root]# iptunnel add try mode ipip
[root@paul /root]# insmod ip_gre
[root@paul /root]# iptunnel add try mode gre
ioctl: Invalid argument
[root@paul /root]# iptunnel
tunl0: ip/ip  remote any  local any  ttl inherit  nopmtudisc
gre0: gre/ip  remote any  local any  ttl inherit  nopmtudisc
[root@paul /root]#


------- Additional Comments From jbj@redhat.com  08/02/99 10:14 -------
Can you send me the commands that you are running on each i386 machine
so that I can reproduce this problem? Thanks ...


Note You need to log in before you can comment on or make changes to this bug.