Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4337 - On the version of gd that is included in RawHide...
Summary: On the version of gd that is included in RawHide...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gd
Version: 1.0
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-03 22:10 UTC by Jay Freeman
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-27 23:34:19 UTC


Attachments (Terms of Use)

Description Jay Freeman 1999-08-03 22:10:37 UTC
I can see why upgrading to 1.6.* might cause problems for
some people due to the lack of gif file type support in the
library, but is there a reason why gd isn't upgraded to
version 1.5 (which is surely available from somewhere, even
though the author no longer gives it to people)?

Comment 1 Jeff Johnson 1999-08-27 15:35:59 UTC
The legal issues surrounding the Unisys GIF patent make upgrading
tto gd 1.anything complicated. We'll leave this one alone, thank you.

Comment 2 Jay Freeman 1999-08-27 16:35:59 UTC
That seems opposite then, since 1.6 no longer supports GIF files in
order to totally eradicate the problem until the issue is resolved,
yet the version of gd that is in RawHide DOES support GIF files, and
therefor WOULD have "complications"...  1.3 (what RawHide has)
through 1.5 didn't even use LZW compression, and used run length
encoding instead, in an effort to get around the problem anyway
(which would therefor make moving from 1.3 to 1.5 or anything else a
moot issue since all versions have the same problems, the same number
of complications, just newer features).  If you really wanted to
avoid this issue entirely, you would upgrade to 1.6.  This is my last
argument, simply to clarify issues that I think were misunderstood, I
will not carry this issue further if you still don't wish to upgrade.

Comment 3 Cristian Gafton 1999-08-27 23:34:59 UTC
the new gd 1.5 has a significantly improved interface that will break
badly the backwards compatibility we are shooting for between our next
release and Red Hat Linux 6.0.

Also this type of changes from its changelog are making me king of
nervous:

""
New GD2 format
     An improvement over the GD format, the GD2 format uses the zlib
compression library to compress the image in chunks. This results in
file sizes comparable to GIFs, with the ability to access parts of
large images without having to read the entire image into memory.
""

I understand fighting the compression algorithms by prividing none,
not by implementing "comparable" ones that can be much easily
challenged.


Note You need to log in before you can comment on or make changes to this bug.