Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 433433 - ocaml gsl - bindings to the GNU scientific library
Summary: ocaml gsl - bindings to the GNU scientific library
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ocaml
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL: http://oandrieu.nerim.net/ocaml/gsl/
Whiteboard:
Depends On: 435983
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-19 09:30 UTC by Richard W.M. Jones
Modified: 2008-04-25 17:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-25 17:21:44 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2008-02-19 09:30:19 UTC
ocamlgsl are OCaml bindings to the GNU scientific library.
A spec file is included in the tarball.

This is a tracking bug for packaging this library.

Comment 1 Richard W.M. Jones 2008-02-20 13:55:24 UTC
Hezekiah: Please can you try this package and post your results here.

http://www.annexia.org/tmp/ocaml/ocaml-gsl-0.6.0-1.fc8.src.rpm

Comment 2 Hezekiah M. Carty 2008-03-04 18:37:59 UTC
I have built the RPM on a x86 32bit CentOS 5 system using manually recompiled
OCaml 3.10.0 packages from Fedora.  The packages were able to build and pass a
few basic tests (compiling and testing a program which uses the library).

It looks good from here.

Comment 3 Richard W.M. Jones 2008-03-04 18:44:38 UTC
I'll put in a review request for this package shortly.

Comment 4 Hezekiah M. Carty 2008-03-30 00:39:51 UTC
For what it's worth, I tried to build the given ocaml-gsl .src.rpm on my F9pre
partition, and got the following result:

(lots of snipped output in which everything looks fine...)
Installed /var/tmp/ocaml-gsl-0.6.0-1.fc9-root-hcarty/usr/lib/ocaml/gsl/META
Installed
/var/tmp/ocaml-gsl-0.6.0-1.fc9-root-hcarty/usr/lib/ocaml/stublibs/dllmlgsl.so
Installed
/var/tmp/ocaml-gsl-0.6.0-1.fc9-root-hcarty/usr/lib/ocaml/stublibs/dllmlgsl.so.owner
ocamlfind: [WARNING] You have installed DLLs but the directory
/var/tmp/ocaml-gsl-0.6.0-1.fc9-root-hcarty/usr/lib/ocaml/stublibs is not
mentioned in ld.conf
+ install -m 0644 gsl_blas.mli gsl_blas_flat.mli gsl_blas_gen.mli
gsl_bspline.mli gsl_cdf.mli gsl_cheb.mli gsl_complex.mli gsl_const.mli
gsl_diff.mli gsl_eigen.mli gsl_error.mli gsl_fft.mli gsl_fit.mli gsl_fun.mli
gsl_histo.mli gsl_ieee.mli gsl_integration.mli gsl_interp.mli gsl_linalg.mli
gsl_math.mli gsl_matrix.mli gsl_matrix_complex.mli gsl_matrix_complex_flat.mli
gsl_matrix_flat.mli gsl_min.mli gsl_monte.mli gsl_multifit.mli
gsl_multifit_nlin.mli gsl_multimin.mli gsl_multiroot.mli gsl_odeiv.mli
gsl_permut.mli gsl_poly.mli gsl_qrng.mli gsl_randist.mli gsl_rng.mli
gsl_root.mli gsl_sf.mli gsl_siman.mli gsl_sort.mli gsl_stats.mli gsl_sum.mli
gsl_vectmat.mli gsl_vector.mli gsl_vector_complex.mli
gsl_vector_complex_flat.mli gsl_vector_flat.mli gsl_wavelet.mli
/var/tmp/ocaml-gsl-0.6.0-1.fc9-root-hcarty/usr/lib/ocaml/gsl/
+ mkdir -p /var/tmp/ocaml-gsl-0.6.0-1.fc9-root-hcarty//usr/share/info
+ install -m 644 ocamlgsl.info ocamlgsl.info-1 ocamlgsl.info-2
/var/tmp/ocaml-gsl-0.6.0-1.fc9-root-hcarty//usr/share/info
+ /usr/lib/rpm/check-rpaths /usr/lib/rpm/check-buildroot
xargs: xargs.c:443: main: Assertion `bc_ctl.arg_max <= (131072-2048)' failed.
/usr/lib/rpm/check-rpaths: line 28:  4618 Done                    find
"$RPM_BUILD_ROOT" -type f -print0
      4619 Aborted                 | xargs -0r /usr/lib/rpm/check-rpaths-worker
error: Bad exit status from /var/tmp/rpm-tmp.92606 (%install)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.92606 (%install)


Comment 5 Caolan McNamara 2008-03-31 11:43:57 UTC
The args foo is rhbz#439168 and should be fixed now

Comment 6 Richard W.M. Jones 2008-03-31 12:05:33 UTC
Comment 4 is a bug in xargs (see bug 439168).

This will work if you upgrade glibc and findutils to at least:
  glibc-2.7.90-13
  findutils-4.2.33-2.fc9

Comment 7 Hezekiah M. Carty 2008-04-09 18:49:19 UTC
I tested the package again today and it seems to build and function properly on
a fairly up to date F9 install.

Comment 8 Richard W.M. Jones 2008-04-25 17:21:44 UTC
This is approved for Fedora now, so closed.


Note You need to log in before you can comment on or make changes to this bug.