Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 431442 - PCI passthrough fails after reboot
Summary: PCI passthrough fails after reboot
Keywords:
Status: CLOSED DUPLICATE of bug 233801
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen
Version: 5.1
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Xen Maintainance List
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-04 15:21 UTC by Andreas Thienemann
Modified: 2009-12-14 21:25 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-19 07:31:47 UTC


Attachments (Terms of Use)

Description Andreas Thienemann 2008-02-04 15:21:47 UTC
After rebooting a DomU guest the configured pci passthrough card has vanished:

[root@tyche ~]# uname -a
Linux tyche 2.6.18-53.el5xen #1 SMP Wed Oct 10 17:06:12 EDT 2007 i686 athlon
i386 GNU/Linux
[root@tyche ~]# lspci
00:00.0 Communication controller: Cyclades Corporation Cyclades-Z above first
megabyte (rev 01)
[root@tyche ~]# reboot

Broadcast message from root (pts/1) (Mon Feb  4 16:15:24 2008):

The system is going down for reboot NOW!
[root@tyche ~]# rebootConnection to tyche closed by remote host.
Connection to tyche closed.
[athienem@localhost ~]$ ssh root@tyche
Last login: Mon Feb  4 16:13:14 2008 from nat-pool-str.redhat.com
[root@tyche ~]# lspci
[root@tyche ~]# 

shutting down the guest, waiting and starting it again makes the pci device work
again.
No messages about pci stuff in dmesg.

Comment 1 Andreas Thienemann 2008-02-19 07:31:47 UTC

*** This bug has been marked as a duplicate of 233801 ***


Note You need to log in before you can comment on or make changes to this bug.