Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 431340 - Error in I830WaitLpRing after xrandr + mplayer
Summary: Error in I830WaitLpRing after xrandr + mplayer
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810
Version: 8
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 218683 222818 224226 432590 (view as bug list)
Depends On:
Blocks: f9-x-blocker
TreeView+ depends on / blocked
 
Reported: 2008-02-03 02:36 UTC by Pat Kane
Modified: 2018-04-11 11:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-29 17:09:18 UTC


Attachments (Terms of Use)
Xorg.0.log from a failure (deleted)
2008-02-03 02:36 UTC, Pat Kane
no flags Details
dmesg output (deleted)
2008-02-03 02:37 UTC, Pat Kane
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 222818 None None None Never

Description Pat Kane 2008-02-03 02:36:15 UTC
Description of problem:
Xorg X server locks up, and sometimes the entire system hangs
after a "xrandr -o left" is done while mplayer is being used.

Version-Release number of selected component (if applicable):
 smolt profile: 
 http://www.smolts.org/show?UUID=c8eafbcc-07bb-43af-a9c0-8ca1e978a8a5

This is most likely related to "Bugzilla Bug 222818: Error in I830WaitLpRing()"

How reproducible:
Start mplayer running to display live video, using a HDTV 
file seems to cause the worst problems. Then do a "xrandr -o left".

Steps to Reproduce:
1. mplayer hdtv.ts
2. xrandr -o left
3.
  
Actual results:
X server dies, or hangs. Sometimes the 
system hangs without any message on 
a serial console.

Expected results:


Additional info:

Comment 1 Pat Kane 2008-02-03 02:36:15 UTC
Created attachment 293816 [details]
Xorg.0.log from a failure

Comment 2 Pat Kane 2008-02-03 02:37:44 UTC
Created attachment 293817 [details]
dmesg output

Comment 3 Pat Kane 2008-02-03 04:58:04 UTC
Yeah, I know doing an xrandr while playing a video is a stupid 
thing to do... esp. since the video does not rotate with the
rest of the screen.   But it  is  also a bad idea to rotate
the screen and then play a video...


Comment 4 Pat Kane 2008-02-04 18:02:57 UTC
Here is an interesting patch:
   http://lists.freedesktop.org/archives/xorg/2008-February/032634.html
    o_list is corrupted when we call i830_free_3d_memory. 
    This happens when the virtual size is > 2048 for non-965 machine and
    it causes X server segfault because the front buffer is not binded 
    when entering VT.

Comment 5 Adam Jackson 2008-02-12 16:39:54 UTC
Should be fixed with the next -intel rebase.

Comment 6 Matěj Cepl 2008-02-13 10:56:27 UTC
*** Bug 222818 has been marked as a duplicate of this bug. ***

Comment 7 Matěj Cepl 2008-02-13 10:56:32 UTC
*** Bug 432590 has been marked as a duplicate of this bug. ***

Comment 8 Matěj Cepl 2008-02-13 10:58:56 UTC
*** Bug 218683 has been marked as a duplicate of this bug. ***

Comment 9 Matěj Cepl 2008-02-13 10:59:15 UTC
*** Bug 224226 has been marked as a duplicate of this bug. ***

Comment 10 Adam Jackson 2008-04-29 17:09:18 UTC
Closing, intel driver in rawhide should have this sorted now.


Note You need to log in before you can comment on or make changes to this bug.