Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 43010 - RPM allows duplicate filenames on command line and installs the package twice
Summary: RPM allows duplicate filenames on command line and installs the package twice
Keywords:
Status: CLOSED DUPLICATE of bug 7771
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 7.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-31 06:35 UTC by Matt Perry
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2001-05-31 06:35:47 UTC


Attachments (Terms of Use)

Description Matt Perry 2001-05-31 06:35:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
I'm trying this with RPM v4.0.2 on RH 7.1 on an Intel box.
If you give a command as follows: rpm -Fvh gnupg-1.0.5-1.i386.rpm *

RPM will see the gnupg package twice and will install it twice with the 
following output:

[root@ns2 patches]# rpm -Fvh gnupg-1.0.5-1.i386.rpm *
Preparing...                ########################################### 
[100%]
   1:gnupg                  ########################################### [ 
50%]
   2:gnupg                  ########################################### 
[100%]

While this didn't seem to cause any problems, maybe RPM should check the 
package names and silently remove duplicates.

How reproducible:
Always

Steps to Reproduce:
Use RPM to install or upgrade a package and give the package name twice on 
the command line.
	

Actual Results:  RPM appeared to install the package twice.


Expected Results:  RPM should have silently removed the duplicate package 
name from the command line and installed the package only once.

Additional info:  none

Comment 1 Jeff Johnson 2001-06-06 17:27:32 UTC

*** This bug has been marked as a duplicate of 7771 ***


Note You need to log in before you can comment on or make changes to this bug.