Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4288 - ftp gives "ftp: ftp/tcp: unknown service" for regular user
Summary: ftp gives "ftp: ftp/tcp: unknown service" for regular user
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ftp
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-31 17:50 UTC by Bertil Askelid
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-01 09:02:31 UTC


Attachments (Terms of Use)

Description Bertil Askelid 1999-07-31 17:50:38 UTC
/usr/bin/ftp has to installed with suid bit set:

	chmod 4755 /usr/bin/ftp

Same error occures for telnet and fwhois.

Comment 1 Bertil Askelid 1999-07-31 18:53:59 UTC
My suggested solution is no good. Means that ftp:ed files are owned
by root. Thus, there must be something in the tcp that prevents ftp,
telnet and fwhois to be used by a regular user. But what?

Comment 2 Bertil Askelid 1999-07-31 19:31:59 UTC
Problem solved: /etc/services comes with rw------- on the 6.0 CD.
Should be rw-r--r--.

Comment 3 Bill Nottingham 1999-07-31 21:46:59 UTC
No, it comes with the correct 644 permissions (just checked here.)
Perhaps something else changed them on your system. Did you install
the samba upgrade with a non-default root umask?

Comment 4 Jeff Johnson 1999-07-31 23:03:59 UTC
No, don't put a setuid on the program, check the permissions
on /etc/services. I believe that a recent update (samba?)
changes the permissions to 600 on /etc/servcies. Can you confirm
whether:
   1) you recently installed the samba update.
   2) the permissions are 600 on /etc/services
so I can get this problem fixed? Thanks ...

Comment 5 Jeff Johnson 1999-08-01 09:02:59 UTC
This problem appears to be resolved.


Note You need to log in before you can comment on or make changes to this bug.