Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4286 - problem with XFree86 and kppp
Summary: problem with XFree86 and kppp
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdenetwork
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-31 16:50 UTC by bpinaud
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-02 12:54:01 UTC


Attachments (Terms of Use)

Description bpinaud 1999-07-31 16:50:18 UTC
I've have the latest version of kde and XFree86 and there is
still a problem when i'm connected to the internet using
kppp. The problem is that the X server (i use the Mach64
server) is refusing connection to all X applications so
before going on the web i've have to start all applications
i want to use during my kppp session.

Comment 1 Jay Turner 1999-08-02 12:54:59 UTC
This is actually not a problem with kppp or even KDE itself, but
rather with CORBA.  CORBA is trying to perform a reverse lookup of the
hostname before starting any applications.  I am assuming that your
hostname is currently set to localhost.localdomain.  This being the
case, then you dial up to your ISP, the network scripts that get
executed are assigning you a new hostname, and therefore CORBA is not
able to perform that reverse lookup anymore and you see what happens.
To solve this problem, give your machine a real hostname (check "man
hostname") and then add this entry to your /etc/hosts file (mimic the
entry which is already there for localhost)  This way when you dial
up, you will not get a new hostname (since you have already assigned
one) and CORBA will be able to perform the reverse lookup because the
assignment is given in /etc/hosts.


Note You need to log in before you can comment on or make changes to this bug.