Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 428532 - NetworkManager cannot handle static IP connection
Summary: NetworkManager cannot handle static IP connection
Keywords:
Status: CLOSED DUPLICATE of bug 134886
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 8
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-12 22:32 UTC by Pavel Šefránek
Modified: 2008-02-01 21:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-01 21:35:00 UTC


Attachments (Terms of Use)

Description Pavel Šefránek 2008-01-12 22:32:25 UTC
NetworkManager included in F8 is unsuable, because it cannot handle my static IP
connection. It absolutely ignore all that /etc/sysconfig/net* scripts and trying
a long time to obtain wrong settings.

In F7 it works with no problem.

With this strange behavior of 0.7.0 NM makes no sense.

Comment 1 Pavel Šefránek 2008-02-01 20:51:38 UTC
Any updates Dan?

Comment 2 Dan Williams 2008-02-01 21:26:31 UTC
The system settings daemon works already for those configurations that ifcfg-*
files support (ie, Ethernet and unencrypted/WEP Wifi).  Since ifcfg-* files
don't support WPA yet (working on that now...) we can't do WPA before login yet.
 The applet bits are mostly done, needed to intelligently display all available
connections (both system and user) and allow the user to choose between them. 
Have to set up the D-Bus service activation stuff for the system settings daemon
and get NM to service activate it too.  Mostly cleanups, the heavy lifting is done.

I hope to land some stuff in Rawhide early next week.

Beyond the system settings daemon, static IP should already Just Work if you
have set up the right bits in GConf.  The connection editor that would allow you
to set up static IP without the system settings daemon isn't quite there yet.

Comment 3 Dan Williams 2008-02-01 21:35:00 UTC

*** This bug has been marked as a duplicate of 134886 ***


Note You need to log in before you can comment on or make changes to this bug.