Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 428 - messages in /var/log/messages reports incorrect logout times
Summary: messages in /var/log/messages reports incorrect logout times
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: aboot
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-15 15:55 UTC by esisler
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-12-16 19:34:17 UTC


Attachments (Terms of Use)

Description esisler 1998-12-15 15:55:39 UTC
I'm not actually sure if this is being caused by sysklogd
or some other package.  I have applied all RPM's from the
errata pages and still notice the following in
/var/log/messages:

Dec 15 08:45:20 bighat login[294]: ROOT LOGIN on tty2
Dec 15 08:45:20 bighat PAM_pwdb[294] (login) session closed
for user root

Even though I'm still logged in, it looks as though I logged
in and then right back out.

Any help would be most appreciated.  Thanks for making a
great product.

-Eric

Comment 1 Jeff Johnson 1998-12-15 16:10:59 UTC
Some over zealous hacking in util-linux-2.[89] to remove
an "extra" process resulted in PAM credentials being discarded
before forking the user's shell rather than after the shell
exits. The good old util-linux-2.7 behavior (fork and waitpid)
has been restored.

Try the Raw Hide util-linux-2.9-4 rpm and repopen this bug if that
rpm does not fix your problem.

Comment 2 esisler 1998-12-15 20:24:59 UTC
I can't upgrade to util-linux-2.8-11 (rawhide) without upgrading to
slang-1.2.2-3 (rawhide), which in turn would require updating a bunch
of other packages, including: gecko, kbdconfig, mc, mouseconfig, newt,
ntsysv, rhs-hwdiag, timeconfig, tkmc & Xconfigurator.  I'd rather stay
at the relase 5.2 level if possible since this will be a production
server.

Any other ideas?  Thanks!

Comment 3 Bill Nottingham 1998-12-15 22:43:59 UTC
You can upgrade the RPM by using rpm --nodeps -U util-linux-blah...
unless you're planning on using cfdisk, you won't have a problem.
Alternatively, you can rebuild the rawhide RPM.

Comment 4 Jeff Johnson 1998-12-16 19:34:59 UTC
There is an errata item for util-linux-2.9-4 on Red Hat 5.2
that will be out Real Soon Now.


Note You need to log in before you can comment on or make changes to this bug.