Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4230 - Invalid DatagramSocket option
Summary: Invalid DatagramSocket option
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netscape
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-27 21:54 UTC by gailizhao
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-24 16:38:26 UTC


Attachments (Terms of Use)

Description gailizhao 1999-07-27 21:54:01 UTC
Hi,

I have an applet that performs a multicast function on a
Linux machine.  The browser is Netscape communicator 4.51.
The applet is a signed applet and has passed
the "Multicast" privilege checking when the applet is
executed. Right after the privilege checking, the applet
attempts to instantiate a multicastSocket with the
following code: DatagramSocket socket = new MulticastSocket
(6666); At this point, a SocketException occurrs.

The Stack traces are:
invalid DatagramSocket option
at java.net.PlainDatagramSocketImpl.setOption
(PlainDatagramSocketImpl.java:156)
at java.net.MulticastCreate (MulticastSocket.java:111)
at java.net.DatagramSocket. (DatagramSocket.java:115)
at java.net.DatagramSocket. (DatagramSocket.java:101)
at java.net.MulticastSocket. (MulticastSocket.java:92)
at inria.net.MulticastSession.run
(MulticastSession.java:205)  applet code
at java.lang.Thread.run (Thread.java:504)

Note: The same applet running with Netscape communicator
4.51 under Windows is OK.

Can someone tell me what's the cause of this problem?

Thanks.

Larry Hsiao
Foresyte Technologies, Inc.

Comment 1 Bill Nottingham 1999-07-29 16:42:59 UTC
Do you have multicast support compiled into your kernel?

Comment 2 Bill Nottingham 1999-08-24 16:38:59 UTC
Corfirmed and reported to Netscape. Unfortunately, since we
don't control the netscape source code, we can't really
fix this.


Note You need to log in before you can comment on or make changes to this bug.