Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 422391 - Anaconda installer hangs while trying to install Red Hat 5 Server 64bit on systems using a 3WARE SATA RAID Controller 8006 series (3w_xxxx driver) and 4GB of more of RAM
Summary: Anaconda installer hangs while trying to install Red Hat 5 Server 64bit on s...
Status: CLOSED DUPLICATE of bug 451945
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.1
Hardware: x86_64
OS: Linux
Target Milestone: ---
: ---
Assignee: Doug Ledford
QA Contact: Martin Jenner
Depends On:
TreeView+ depends on / blocked
Reported: 2007-12-12 20:30 UTC by Andres Barcenas
Modified: 2008-06-18 10:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-06-18 10:07:46 UTC
Target Upstream Version:

Attachments (Terms of Use)

Description Andres Barcenas 2007-12-12 20:30:34 UTC
Description of problem:

There seems to be a bug with the anaconda installer for Red Hat Enterprise Linux
(v. 5 for 64-bit x86_64) using the 3WARE  SATA RAID CONTROLLER 8006 series and
4GB or more of memory. The anaconda installer formats the hard drives and
installs some of the RPMS but it eventually hangs (between 15 to 20 percent).
The same system was used with 3GB and it installs without a problem. The problem
only occurs on systems with the 3WARE RAID SATA 8006 model which uses the
3w_xxxx kernel driver. 

	3WARE Raid adapters used for testing:

	8006S-2LP		4GB	3w-xxxx		FAILED
	8006S-2LP		3GB	3w-xxxx		WORKED
	8006S-2LP		8GB	3w-xxxx		FAILED
	9500-4LP		3GB 	3w-9xxx		WORKED
	9500-4LP		4GB 	3w-9xxx		WORKED
	9500-4LP		8GB 	3w-9xxx		WORKED

It seems as though the problem is directly related to the 3w-xxxx driver on
RedHat 5 64BIT Kernel using 4GB. I have tried using LSI RAID controllers and the
3WARE SATA RAID controller 9500 series and did not experience any problems while

I also wanted to point out the fact that the system can be installed with 3GB
but when the 4GB are added I notice some strange problems such as RPM corruption
and unable to untar files

Version-Release number of selected component (if applicable):

Server Components:
* MotherBoard:  Model MB-PDSMI+
* Processor: E6300 - CORE 2 DUO 1.86Ghz
* Memory: 4x1GB/ SUPER TALENT 1GB 240 pins PC2-5400 DDR2 667 Computer Memory
* Raid Controller: 3WARE RAID SATA 8006 2PT KIT  (3WA80062LP)
* Hard Drives: 2x250GB Raid One (WD2500JS SATA II 250G 8MB/7200)

RedHat Version: Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)
Kernel Version: 2.6.18-53.1.4.el5
Install Method: Kickstart/Anaconda

How reproducible:

1. Attempt to install RedHat Version: Red Hat Enterprise Linux (v. 5 for 64-bit
x86_64) WITH 4GB of RAM via kickstart using a 3WARE SATA RAID Controller 8006
series or any 3WARE SATA RAID that uses the 3w-xxxx kernel driver.
2. Installer hangs while installing the RPMS between 15 to 20 percent. You can
still go through the different screens and see the anaconda process using CPU,
but it does not do anything.
3. Attempt using the same system with less than 4GB and the install completes.

Comment 2 Andres Barcenas 2007-12-28 18:18:10 UTC
Additional information from another user having the same problem:

Comment 4 Adam C. Greenfield 2008-06-13 00:38:57 UTC
This issue is still present in RHEL 5.2

Note You need to log in before you can comment on or make changes to this bug.