Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4198 - Glint fails with new rpm-3.0.x
Summary: Glint fails with new rpm-3.0.x
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glint
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
: 4795 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-24 19:30 UTC by Simon Hill
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-19 18:50:31 UTC


Attachments (Terms of Use)

Description Simon Hill 1999-07-24 19:30:01 UTC
After installing the new rpm-3.0.2-5.x, and
rebuilding the rpm database with rpm --rebuilddb,
glint was unable to read the new rpm database format.

Traceback (innermost last):
  File "./glint.py", line 49, in ?
    installedPackageSet = InstalledPackageSet()
  File "./packageset.py", line 133, in __init__
    self.db = RPMDatabase(prefix)
  File "./rpmdb.py", line 61, in __init__
    self.OpenDatabase(Prefix)
  File "./rpmdb.py", line 26, in OpenDatabase
    self.reopen()
  File "./rpmdb.py", line 41, in reopen
    self.db = rpm.opendb()
rpm.error: cannot open database in /var/lib/rpm

Comment 1 Bill Nottingham 1999-08-31 15:59:59 UTC
*** Bug 4795 has been marked as a duplicate of this bug. ***

After upgrading to the latest rpm (3.0.2) from your Support
list, glint does not work.  Also, the X-Windows Package
Management tool (which envokes glint) does not work.
Executing glint from the command line results in the
following messages:
  bad option 'macrofiles' at /usr/lib/rpm/rpmrc:256
  Glint Graphical Package Manager -- version 2.6.2
  Copyright (C) 1998 - Red Hat Software
  This may be freely redistributed under the terms of the
   GNU Public License
  Traceback (innermost last):
    File "./glint.py", line 49, in ?
      installedPackageSet = InstalledPackageSet()
    File "./packageset.py", line 133, in __init__
      self.db = RPMDatabase(prefix)
    File "./rpmdb.py", line 61, in __init__
      self.OpenDatabase(Prefix)
    File "./rpmdb.py", line 26, in OpenDatabase
      self.reopen()
    File "./rpmdb.py", line 41, in reopen
      self.db = rpm.opendb()
  rpm.error: cannot open database in /var/lib/rpm

I downloaded the rpm and rpm-devel RPMs from the errata
list, and did a "rpm --rebuilddb".  Problem persists.

Comment 2 David Lawrence 1999-09-19 18:50:59 UTC
Glint has been deprecated and will probably disappear in following
releases. Gnorpm as was shipped with 6.0 is a better and more modern
choice for rpm package maintenance.


Note You need to log in before you can comment on or make changes to this bug.