Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4191 - wrong chkconfig stuff
Summary: wrong chkconfig stuff
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: bind
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-24 01:35 UTC by dharris
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-26 19:01:19 UTC


Attachments (Terms of Use)

Description dharris 1999-07-24 01:35:24 UTC
bind-8.2.1-3 /etc/rc.d/init.d/named has the line
# chkconfig: - 55 45
when it should be
# chkconfig: 345 55 45

Comment 1 Bill Nottingham 1999-07-26 17:04:59 UTC
Nope. It's a change in policy; we don't want to start named
automatically if installed anymore. chkconfig --add shouldn't
change existing links, though (if it does, that is a bug).

Of course, now I look at the package and see that the scripts
that it includes don't mesh with this. Will fix.

Comment 2 dharris 1999-07-26 18:41:59 UTC
The "chkconfig: - 55 45" line works to make named install by default
as non-running, but the problem is that I can't enable the service
using chkconfig... that line basically "short-circuits" chkconfig's
definition of the service running so that "chkconfig --add named" and
"chkconfig --del named" have the same effect. To enable the service I
have to manually create the symlinks. The whole purpose of chkconfig
was to keep me from having to manually create these links.

Wouldn't it just be better to leave the "chkconfig: 345 55 45" line
alone and change the "chkconfig --add" line in the postinstall script
to "chkconfig --del" to implement this policy change?

Comment 3 Bill Nottingham 1999-07-26 18:47:59 UTC
Actually, the chkconfig behavior works like this:

chkconfig --add adds the default links specified in the
init file.
chkconfig --del removes *all* links.

To enable a service using chkconfig, regardless of the initfile
defaults, do something like:

chkconfig --level 345 named on

(The --level argument is a list of runlevels. --level <foo> is
optional.)

Comment 4 dharris 1999-07-26 18:57:59 UTC
Oh, that's funny. I've been using chkconfig wrong all this time and
I've not gotten bitten yet. :-) Sorry about the erroneous bug report.

Comment 5 Bill Nottingham 1999-07-26 19:01:59 UTC
That's OK. At least it caused me to notice the
bind chkconfig & links disagreeing. :)


Note You need to log in before you can comment on or make changes to this bug.