Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4190 - hyphenation broken in latex
Summary: hyphenation broken in latex
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 4188 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-24 00:51 UTC by ignat
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-26 21:21:17 UTC


Attachments (Terms of Use)

Description ignat 1999-07-24 00:51:07 UTC
Hyphenation is broken in latex / tetex-latex-0.9-17 as in
RH 6.0.

The issue is that \lefthyphenmin and \righthyphenmin are not
reported properly to latex, although they seem to be in the
config files
at the right values.

The result is hyphenation of the word ``you'' across lines
as in ``y-ou'' for example

This problem did not exist in any previous RH version.  In
fact no errors of any kind have ever been encountered in RH
latex rpms, from 4.1 up until 6.0

Of course, there may be other things broken.


Here is a simple file showing the problem.

\documentclass{article}
\newcounter{LANG}  \setcounter{LANG}{\language}        %
default should be 0
\newcounter{LEFT}  \setcounter{LEFT}{\lefthyphenmin}   %
default should be 2
\newcounter{RIGHT} \setcounter{RIGHT}{\righthyphenmin} %
default should be 3
\typeout{TESTING -hyphenmin.  left is \theLEFT ; right is
\theRIGHT }
\typeout{TESTING language; it is \theLANG }
\begin{document}
Hello, world.  Left is \theLEFT ; Right is \theRIGHT
\end{document}
% Results !
% TESTING -hyphenmin. left is -1; right is 0
% TESTING language; it is 0
%

Comment 1 Jeff Johnson 1999-07-26 21:21:59 UTC
Hyphenation problems are fixed in tetex-1.0.5 from Raw Hide.

Comment 2 Jeff Johnson 1999-07-26 21:25:59 UTC
*** Bug 4188 has been marked as a duplicate of this bug. ***

Latex hyphens at very short and improper places.  I think
this is supposed to be fixed in the next release of tetex.
I tried intstalling the tetex packages from rawhide several
times but they don't install properly and latex does not
run.


Note You need to log in before you can comment on or make changes to this bug.