Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4177 - samba install leads to loss of read permission /etc/services
Summary: samba install leads to loss of read permission /etc/services
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
: 4257 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-23 14:44 UTC by ae
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-23 15:10:49 UTC


Attachments (Terms of Use)

Description ae 1999-07-23 14:44:54 UTC
if root's umask os 066, then
rpm -Uvh 2.0.5a-1.i386.rpm leads to no group, other
read permission on /etc/services, /etc/inetd.conf.

In the first case, this breaks (at least) Powell's LPRng,
and one supposes will cause trouble in general.
See the 'mv' lines in the postuninstall script.

In the second case, no trouble identified but it seems
unusual.

Comment 1 Bill Nottingham 1999-07-23 14:59:59 UTC
fixed in samba-2.0.5a-2, which will be in next Raw Hide release.

Comment 2 Bill Nottingham 1999-07-23 15:10:59 UTC
Unfortunately, since the problem is in the %postun of the
*previous* version, you might still have to chmod them back
later.

Comment 3 Bill Nottingham 1999-07-29 21:35:59 UTC
*** Bug 4257 has been marked as a duplicate of this bug. ***

I installed the upgrade rpm and it changed permissions on
/etc/services from rw-r-r to rw--.  As a result, outgoing
telnet and ftp broke.

I've done this on 2 separate RH6.0 machines, and on the
second I observed that the samba rpm actually did cause the
problem (before and after comparison)


Note You need to log in before you can comment on or make changes to this bug.