Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4175 - Kickstart post install cannot install extra RPMS
Summary: Kickstart post install cannot install extra RPMS
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-23 11:31 UTC by chris.picton
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-23 16:18:43 UTC


Attachments (Terms of Use)

Description chris.picton 1999-07-23 11:31:10 UTC
If in the kickstart rpm list, the X-windows rpms are not
selected, then you are unable to install any extra rpms in
the kickstart post install section.

This is caused by the rpm database being opened, in the
setupXfree function in doit.c, before the check is made for
the installation of X.  If X is not installed, the function
returns, without closing the rpm database.  The rpm db is
now locked for the remainder of the install process.

If the 'check for X' and 'open rpm db' code blocks are
swapped, the function runs without any problems.

Comment 1 Bill Nottingham 1999-07-23 16:18:59 UTC
This is fixed in the latest install2 binary available in
the Raw Hide instimage....


Note You need to log in before you can comment on or make changes to this bug.