Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 416331 - Static IP Configuration doesn't work
Summary: Static IP Configuration doesn't work
Keywords:
Status: CLOSED DUPLICATE of bug 134886
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-08 02:29 UTC by Joshua Rosen
Modified: 2007-12-09 17:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-12-09 17:22:47 UTC


Attachments (Terms of Use)

Description Joshua Rosen 2007-12-08 02:29:40 UTC
Description of problem: Static IP configuration is setting the wrong IP address
on my Compaq R3000z laptop. It should be setting 192.168.1.4 instead it's doing
192.168.1.198

Here is the ifcfg-eth1 script,

GATEWAY=192.168.1.1
TYPE=Ethernet
DEVICE=eth1
HWADDR=00:0f:b0:06:a6:94
BOOTPROTO=none
NETMASK=255.255.255.0
IPADDR=192.168.1.4
ONBOOT=yes
USERCTL=yes
IPV6INIT=yes
PEERDNS=yes

Here is the output from ifconfig


ifdown eth1
/home/bjrosen> ifup eth1
/home/bjrosen> ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 00:0F:B0:06:A6:94  
          inet addr:192.168.1.198  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::20f:b0ff:fe06:a694/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:222 errors:0 dropped:0 overruns:0 frame:0
          TX packets:222 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:66392 (64.8 KiB)  TX bytes:27417 (26.7 KiB)
          Interrupt:18 Base address:0x6800 

In /var/log/messages 

Dec  7 21:25:14 ranger NetworkManager: <info>  Activating device eth1
Dec  7 21:25:14 ranger NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) scheduled...
Dec  7 21:25:14 ranger NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) started...
Dec  7 21:25:14 ranger NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) scheduled...
Dec  7 21:25:14 ranger NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) complete.
Dec  7 21:25:14 ranger NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) starting...
Dec  7 21:25:14 ranger NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) successful.
Dec  7 21:25:14 ranger NetworkManager: <info>  Activation (eth1) Stage 3 of 5
(IP Configure Start) scheduled.
Dec  7 21:25:14 ranger NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) complete.
Dec  7 21:25:14 ranger NetworkManager: <info>  Activation (eth1) Stage 3 of 5
(IP Configure Start) started...
Dec  7 21:25:14 ranger NetworkManager: <info>  Activation (eth1) Beginning DHCP
transaction.
Dec  7 21:25:14 ranger NetworkManager: <info>  dhclient started with pid 4327
Dec  7 21:25:14 ranger NetworkManager: <info>  Activation (eth1) Stage 3 of 5
(IP Configure Start) complete.
Dec  7 21:25:14 ranger dhclient: Internet Systems Consortium DHCP Client
V3.0.6-Fedora
Dec  7 21:25:14 ranger dhclient: Copyright 2004-2007 Internet Systems Consortium.
Dec  7 21:25:14 ranger dhclient: All rights reserved.
Dec  7 21:25:14 ranger dhclient: For info, please visit http://www.isc.org/sw/dhcp/
Dec  7 21:25:14 ranger dhclient: 
Dec  7 21:25:14 ranger dhclient: wmaster0: unknown hardware address type 801
Dec  7 21:25:14 ranger NetworkManager: <info>  DHCP: device eth1 state changed
normal exit -> preinit
Dec  7 21:25:14 ranger dhclient: wmaster0: unknown hardware address type 801
Dec  7 21:25:14 ranger dhclient: Listening on LPF/eth1/00:0f:b0:06:a6:94
Dec  7 21:25:14 ranger dhclient: Sending on   LPF/eth1/00:0f:b0:06:a6:94
Dec  7 21:25:14 ranger dhclient: Sending on   Socket/fallback
Dec  7 21:25:14 ranger dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67
interval 3
Dec  7 21:25:14 ranger dhclient: DHCPOFFER from 192.168.1.1
Dec  7 21:25:14 ranger dhclient: DHCPREQUEST on eth1 to 255.255.255.255 port 67
Dec  7 21:25:14 ranger dhclient: DHCPACK from 192.168.1.1
Dec  7 21:25:14 ranger NetworkManager: <info>  DHCP: device eth1 state changed
preinit -> bound
Dec  7 21:25:14 ranger NetworkManager: <info>  Activation (eth1) Stage 4 of 5
(IP Configure Get) scheduled...
Dec  7 21:25:14 ranger NetworkManager: <info>  Activation (eth1) Stage 4 of 5
(IP Configure Get) started...
Dec  7 21:25:14 ranger NetworkManager: <info>    address 192.168.1.198
Dec  7 21:25:14 ranger NetworkManager: <info>    netmask 255.255.255.0
Dec  7 21:25:14 ranger NetworkManager: <info>    broadcast 192.168.1.255
Dec  7 21:25:14 ranger NetworkManager: <info>    gateway 192.168.1.1
Dec  7 21:25:14 ranger NetworkManager: <info>    nameserver '192.168.1.1'
Dec  7 21:25:14 ranger NetworkManager: <info>    domain name 'hsd1.ma.comcast.net.'
Dec  7 21:25:14 ranger NetworkManager: <info>  Activation (eth1) Stage 5 of 5
(IP Configure Commit) scheduled...
Dec  7 21:25:14 ranger NetworkManager: <info>  Activation (eth1) Stage 4 of 5
(IP Configure Get) complete.
Dec  7 21:25:14 ranger NetworkManager: <info>  Activation (eth1) Stage 5 of 5
(IP Configure Commit) started...
Dec  7 21:25:14 ranger dhclient: bound to 192.168.1.198 -- renewal in 41979 seconds.
Dec  7 21:25:14 ranger avahi-daemon[1852]: Joining mDNS multicast group on
interface eth1.IPv4 with address 192.168.1.198.
Dec  7 21:25:14 ranger avahi-daemon[1852]: New relevant interface eth1.IPv4 for
mDNS.
Dec  7 21:25:14 ranger avahi-daemon[1852]: Registering new address record for
192.168.1.198 on eth1.IPv4.
Dec  7 21:25:15 ranger NetworkManager: <info>  Activation (eth1) successful,
device activated.
Dec  7 21:25:15 ranger NetworkManager: <info>  Activation (eth1) Stage 5 of 5
(IP Configure Commit) complete.
Dec  7 21:25:15 ranger avahi-daemon[1852]: Registering new address record for
192.168.1.4 on eth1.IPv4.
Dec  7 21:25:16 ranger avahi-daemon[1852]: Registering new address record for
fe80::20f:b0ff:fe06:a694 on eth1.*.

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Dan Williams 2007-12-09 17:22:47 UTC

*** This bug has been marked as a duplicate of 134886 ***


Note You need to log in before you can comment on or make changes to this bug.