Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4159 - keyboard is not functional on problematic boots
Summary: keyboard is not functional on problematic boots
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 6.0
Hardware: sparc
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-22 14:25 UTC by Viraj Alankar
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-31 20:01:40 UTC


Attachments (Terms of Use)

Description Viraj Alankar 1999-07-22 14:25:04 UTC
When booting up and there is a failure to mount a
filesystem, Redhat prompts for root password or ctrl-d for
normal startup. At this point no matter what is entered it
is considered a failed password attempt. Even ctrl-d will
not work. Pressing ctrl-c a couple of times will break out
and drop to a shell prompt.

Comment 1 Jay Turner 1999-07-22 15:03:59 UTC
My guess would be that the filesystem that is having trouble getting
mounted has /etc on it, therefore no password is going to be accepted.
There is really nothing that can be done about this short of booting
from a rescue disk and trying to repair the filesystem.  Reopen this
bug if the filesystem which is having the problems is not the root
filesystem.

Comment 2 Viraj Alankar 1999-07-22 20:56:59 UTC
/ was mounted read-only and /etc/passwd (and shadow) were accessible
when this occurred. The mount failure was on another filesystem.

Comment 3 Bill Nottingham 1999-07-29 19:34:59 UTC
Are you using a particular keymap?

Comment 4 David Miller 1999-08-02 08:29:59 UTC
Guys, this is broken on every single Sparc install.
I detailed this to Jeff slightly over a month ago.
The net result is that any key typed in during this
phase of the boot will send incorrect keycodes to the
kernel.  This is with a default installation, it happens
every time.  My guess is that the loading of keymaps which
happens very very early on in the boot process, is what
corrupts the keyboard codes.

As an experiment to try and figure out whats wrong and
fix this, just change the root filesystem fsck with some
other application program, such as a shell, for testing
purposes.  My prediction is that you'll see the same
behavior because of something funny done by the boot time
loadkeys.

Comment 5 Bill Nottingham 1999-08-02 15:33:59 UTC
Hmm. I can't reproduce this here on two different sparcs running
6.0 - the keyboard is fine both before and after the loadkeys.

Out of curiousity, does /etc/sysconfig/console/default.kmap look
anything like a sun keymap, or does it look totally bogus?

Comment 6 Bill Nottingham 1999-08-31 20:01:59 UTC
closed, lack of input.


Note You need to log in before you can comment on or make changes to this bug.