Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4141 - /etc/profile.d/kde.csh (kdesupport-1.1.1-1)
Summary: /etc/profile.d/kde.csh (kdesupport-1.1.1-1)
Keywords:
Status: CLOSED DUPLICATE of bug 3686
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdesupport
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-21 17:03 UTC by incani
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-23 08:59:38 UTC


Attachments (Terms of Use)

Description incani 1999-07-21 17:03:06 UTC
File /etc/profile.d/kde.csh (kdesupport-1.1.1-1) is wrong.

kdesupport was downloaded from:
ftp://ftp.students.cs.unibo.it
/Mirrors/ftp.redhat.com/redhat/updates/6.0/

Installed file:
-----------------------------------------------------------
# KDE initialization script (csh)
if ( $?KDEDIR ) then
         if ( $KDEDIR == "/usr" ) then
         exit
         endif
endif
setenv KDEDIR /usr
kdepath="${KDEDIR}/bin"    #This is not a valid csh set
if ( echo ${PATH} | grep -q ${kdepath} ) then
  exit                     #The if statement is wrong
endif

setenv PATH "${kdepath}:${PATH}"
-----------------------------------------------------------

Edited file:
-----------------------------------------------------------
# KDE initialization script (csh) (MODIFIED)
if ( $?KDEDIR ) then
         if ( $KDEDIR == "/usr" ) then
         exit
         endif
endif
setenv KDEDIR /usr
echo ${PATH} | grep -q "${KDEDIR}/bin"
if ( $status == 0 ) then
  exit
endif
setenv PATH "${KDEDIR}/bin:${PATH}"
-----------------------------------------------------------
Note. I don't use the variable kdepath (see also kde.sh).
I hope this is ok.

Comment 1 Jeff Johnson 1999-07-23 08:59:59 UTC
*** This bug has been marked as a duplicate of 3686 ***


Note You need to log in before you can comment on or make changes to this bug.