Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4107 - Problems with threads under RH 6.0
Summary: Problems with threads under RH 6.0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 6.0
Hardware: sparc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-19 05:23 UTC by josh
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-28 06:15:08 UTC


Attachments (Terms of Use)

Description josh 1999-07-19 05:23:41 UTC
MySQL has problems creating threads under RH 6.0 due to
what looks like a glibc2 bug. This is actually a regression
to a bug in an earlier release of RH.

If you compile MySQL and then try to run safe_mysqld, it
looks like everything works fine until you take a look and
see that only one MySQL process/thread is running when in
fact three threads are supposed to be created upon MySQL
startup. As a result, the mysqld daemon is useless. It does
not create its unix socket nor does it listen on port 3306
as it's supposed to.

When I had this problem on RH 5.1, upgrading to the latest
glibc libraries fixed the problem. After upgrading to RH
6.0, the problem is back again.

Note that this is on a sun4c workstation (SPARCstation 2).

I don't know whether the regression occured at GNU or at
RedHat, so I'm submitting it here for you to figure out. :)

Comment 1 Cristian Gafton 1999-07-28 06:15:59 UTC
Is the problem still experienced with glibc-2.1.2-1 and later?

Please reopen if the problem still persists.


Note You need to log in before you can comment on or make changes to this bug.