Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4098 - rpm fails to realize a filesystem is RO
Summary: rpm fails to realize a filesystem is RO
Keywords:
Status: CLOSED DUPLICATE of bug 52190
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
: 2531 4870 11121 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-18 13:22 UTC by o.schnapauff
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2001-01-09 15:56:43 UTC


Attachments (Terms of Use)

Description o.schnapauff 1999-07-18 13:22:33 UTC
rpm fails to realize it cannot write  when /usr is mounted
RO and an rpm -e or rpm -U
is done.

Result: partly updated  /deleted rpms that are marked as
updated/deleted in the rpm database.

rpm needs to check if it can write on a filesystem

Comment 1 Jay Turner 1999-07-19 13:42:59 UTC
This issue has been assigned to a developer for further action.

Comment 2 Jeff Johnson 1999-08-19 15:17:59 UTC
*** This bug has been marked as a duplicate of 2531 ***

Comment 3 o.schnapauff 2000-11-01 15:25:18 UTC
This bug has _still_ not been fixed. its bad, esp. when you erase a packet
and /usr is ro - > its erased but all the files under /usr are
still there and there is not way to get rid of them but reinstall and reerase.



Comment 4 o.schnapauff 2000-11-01 15:26:05 UTC
[root@alpha /root]# rpm -qi rpm
Name        : rpm                          Relocations: (not relocateable)
Version     : 4.0                               Vendor: Red Hat, Inc.
Release     : 4.1                           Build Date: Fre 22 Sep 2

is the currently installed rpm

Comment 5 Jeff Johnson 2001-01-08 16:16:49 UTC
*** Bug 4870 has been marked as a duplicate of this bug. ***

Comment 6 Jeff Johnson 2001-01-08 16:17:39 UTC
*** Bug 2531 has been marked as a duplicate of this bug. ***

Comment 7 Jeff Johnson 2001-01-09 15:56:23 UTC
*** Bug 11121 has been marked as a duplicate of this bug. ***

Comment 8 Jeff Johnson 2001-08-30 17:08:49 UTC

*** This bug has been marked as a duplicate of 52190 ***


Note You need to log in before you can comment on or make changes to this bug.