Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4082 - netkit-base-0.10-31, ping -c no longer works properly
Summary: netkit-base-0.10-31, ping -c no longer works properly
Keywords:
Status: CLOSED DUPLICATE of bug 3959
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netkit-base
Version: 6.0
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
: 4149 4169 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-17 00:07 UTC by Larry Fahnoe
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-23 08:20:12 UTC


Attachments (Terms of Use)

Description Larry Fahnoe 1999-07-17 00:07:11 UTC
On the alpha, netkit-base-0.10-29 had the unaligned trap
bug, but after installing netkit-base-0.10-31 (which fixed
the unaligned trap) ping -c does not work properly.

Specifically, "ping -c x unreachable-host" causes ping to
start a stream of pings (as seen by tcpdump) that does not
stop after "x" pings.  Pinging a host that is reachable with
the -c option works properly.

In this case, I use ping -c to bring up a demand ppp link so
I have reverted to the 0.10-29 kit shipped with 6.0 Alpha.

--Larry

Comment 1 David Lawrence 1999-07-22 15:33:59 UTC
I was able to replicate this problem on an alpha and intel machine in
our test lab with this update. I tried to ping www.redhat.com and
ftp.redhat.com which are set up to reject ping requests so therefore I
get the unreachable errors. It seems the -c <some num> option is
ignored when used and a host is unreachable. This is being assigned to
a developer for further review.

Comment 2 Jeff Johnson 1999-07-23 08:09:59 UTC
*** Bug 4169 has been marked as a duplicate of this bug. ***

Here is the transcript of my session notice that I installed
the original rpm ran my test then ran the new rpm and it
failed!

Transcript follows:

[root@jab-linux RPMS]# rpm -U --oldpackage
netkit-base-0.10-29.i386.rpm
[root@jab-linux RPMS]# ls -l /bin/ping
-rwsr-xr-x   1 root     root        14804 Apr  7 17:21
/bin/ping
[root@jab-linux RPMS]# ping -c 1 130.110.238.4
PING 130.110.238.4 (130.110.238.4): 56 data bytes

--- 130.110.238.4 ping statistics ---
1 packets transmitted, 0 packets received, 100% packet loss
[root@jab-linux RPMS]# cd /jbrown/linux/errata
[root@jab-linux errata]# rpm -U netkit-base-0.10-31.i386.rpm
[root@jab-linux errata]# ls -l /biin/ping
ls: /biin/ping: No such file or directory
[root@jab-linux errata]# ls -l /bin/ping
-rwsr-xr-x   1 root     root        17652 Jul  6 09:33
/bin/ping
[root@jab-linux errata]# ping -c 1 130.110.238.4
PING 130.110.238.4 (130.110.238.4) from 130.110.238.80 : 56
data bytes
From jab-linux.isd.ustra.abb.com (130.110.238.80):
Destination Host Unreachable
From jab-linux.isd.ustra.abb.com (130.110.238.80):
Destination Host Unreachable

--- 130.110.238.4 ping statistics ---
2 packets transmitted, 0 packets received, +2 errors, 100%
packet loss
[root@jab-linux errata]#

Comment 3 Jeff Johnson 1999-07-23 08:11:59 UTC
*** Bug 4149 has been marked as a duplicate of this bug. ***



I beleive there is a problem with
netkit-base-0.10-31.is86.rpm I have a
script that pings hosts and ever since I applied the errata
ping now
fails with this error message :

jab-linux.isd.ustra.abb.com:/jbrown/linux/errata$ ping
130.110.238.4
PING 130.110.238.4 (130.110.238.4) from 130.110.238.80 : 56
data bytes
>From jab-linux.isd.ustra.abb.com (130.110.238.80):
Destination Host
Unreachable
>From jab-linux.isd.ustra.abb.com (130.110.238.80):
Destination Host
Unreachable
>From jab-linux.isd.ustra.abb.com (130.110.238.80):
Destination Host
Unreachable

There is no host the at that address and I should not be
getting this
error. I have an original 6.0 install which has a different
date and
size from the original. The dates on the original install
is:

14804 Apr 7 ping

and the new one is:

17652 Jul 6 ping

 This effectivly breaks ping. Which is vital to my script.
Meanwhile I
have moved the older version onto this computer and I have
changed my
script to refernece the old version of ping. If someone
could please
look into why this is happening. Oh the platform is Intel.

                                        Thanks
                                            Jim Brown




------- Additional Comments From dkl@redhat.com  07/22/99 11:10 -------
I could not get this update to fail on a test lab machine running
standard 6.0 with updates.

Comment 4 Jeff Johnson 1999-07-23 08:20:59 UTC
*** This bug has been marked as a duplicate of 3959 ***


Note You need to log in before you can comment on or make changes to this bug.