Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4077 - passwd does not add password to empty field
Summary: passwd does not add password to empty field
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: passwd
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-16 18:06 UTC by mw
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-20 15:14:46 UTC


Attachments (Terms of Use)

Description mw 1999-07-16 18:06:31 UTC
When the password field is empty in /etc/passwd, passwd does
not add the encrypted passwd to the field, and it does not
indicate it with an error.

Here is the complete experiment:

# useradd okidoki
# grep okidoki /etc/passwd
okidoki:!!:519:520::/home/okidoki:/bin/bash
# emacs /etc/passwd         (empty password field)
# grep okidoki /etc/passwd
okidoki::519:520::/home/okidoki:/bin/bash
# passwd okidoki
Changing password for user okidoki
New UNIX password:                     (typed MaciLaci)
Retype new UNIX password:              (MaciLaci)
passwd: all authentication tokens updated successfully
root@moni: ~
# grep okidoki /etc/passwd
okidoki::519:520::/home/okidoki:/bin/bash

How can this be a problem (besides, that I think it is not a
correct behavior) since RH 6.0 does not let you log in w/o
an empty passwd field?


Well, imagine that on a yp server, after emptying the passwd
field, I run passwd (thinking passwd is set), then run

(cd /var/yp; make)

Now, on another older (5.2) RH box on the same NIS domain, I
could log in as okidoki w/o a passwd!  (I ran this
experiment with a 5.2 box as a yp server but passwd-0.58-1
and pwdb-0.58-3 installed).

Let me remark that yppasswd seems to behave correctly, but
linuxconf also gets confused (I guess it is running passwd).

Mate Wierdl

Comment 1 Jay Turner 1999-07-19 14:44:59 UTC
This has been confirmed in the test lab.

Comment 2 Cristian Gafton 1999-09-20 15:14:59 UTC
Should be fixed in the next release.


Note You need to log in before you can comment on or make changes to this bug.